华为交换机MUX VLAN配置示例(汇聚层设备)
首页 > HuaWei > VLAN   作者:圈哥  2016年1月31日 17:03 星期日  字号:   评论:0 条
时间:2016-1-31 17:03   评论:0 条 
 

华为交换机MUX VLAN配置示例(汇聚层设备)

1、组网需求

     MUX-VLAN组网示例图.png

1 MUX-VLAN组网示例图

如上图1所示,在企业网络中,企业所有员工都可以访问企业的服务器。但对于企业来说,希望企业内部部分员工之间可以互相交流,而部分员工之间是隔离的,不能够互相访问。

Switch1位于网络的汇聚层,作为下挂终端设备的网关设备。Switch2Switch3Switch4Switch5Switch6为接入层设备。此时可在Switch1上部署MUX VLAN特性。MUX VLAN不但能够实现企业需求,同时也解决了VLAN ID紧缺问题,也便于网络管理者维护。

 

2、配置思路

2.1、配置主VLANMUX-VLAN功能,并配置VLANIF接口,其IP地址可以作为下挂HostServer的网关IP

2.2.、配置Group-VLAN功能。

2.3、配置Separate-VLAN功能。

2.4、配置接口加入VLAN并使能MUX-VLAN功能。

2.5、配置接入层设备接口加入相应VLAN

 

3、操作步骤

3.1、配置MUX VLAN

# Switch1上创建VLAN2VLAN3VLAN4,并配置VLAN2VLANIF接口,其IP地址可以作为下挂HostServer的网关IP

<HUAWEI> system-view

[HUAWEI] sysname Switch1

[Switch1] vlan batch 2 3 4

[Switch1] interface vlanif 2

[Switch1-Vlanif2] ip address 192.168.100.100 24

[Switch1-Vlanif2] quit

 

# Switch1上配置MUX VLAN中的Group VLANSeparate VLAN

[Switch1] vlan 2

[Switch1-vlan2] mux-vlan

[Switch1-vlan2] subordinate group 3

[Switch1-vlan2] subordinate separate 4

[Switch1-vlan2] quit

 

# Switch1上配置接口加入VLAN并使能MUX VLAN功能。

[Switch1] interface gigabitethernet 1/0/2

[Switch1-GigabitEthernet1/0/2] port link-type trunk

[Switch1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2

[Switch1-GigabitEthernet1/0/2] port mux-vlan enable vlan 2

[Switch1-GigabitEthernet1/0/2] quit

[Switch1] interface gigabitethernet 1/0/3

[Switch1-GigabitEthernet1/0/3] port link-type trunk

[Switch1-GigabitEthernet1/0/3] port trunk allow-pass vlan 3

[Switch1-GigabitEthernet1/0/3] port mux-vlan enable vlan 3

[Switch1-GigabitEthernet1/0/3] quit

[Switch1] interface gigabitethernet 1/0/4

[Switch1-GigabitEthernet1/0/4] port link-type trunk

[Switch1-GigabitEthernet1/0/4] port trunk allow-pass vlan 3

[Switch1-GigabitEthernet1/0/4] port mux-vlan enable vlan 3

[Switch1-GigabitEthernet1/0/4] quit

[Switch1] interface gigabitethernet 1/0/5

[Switch1-GigabitEthernet1/0/5] port link-type trunk

[Switch1-GigabitEthernet1/0/5] port trunk allow-pass vlan 4

[Switch1-GigabitEthernet1/0/5] port mux-vlan enable vlan 4

[Switch1-GigabitEthernet1/0/5] quit

[Switch1] interface gigabitethernet 1/0/6

[Switch1-GigabitEthernet1/0/6] port link-type trunk

[Switch1-GigabitEthernet1/0/6] port trunk allow-pass vlan 4

[Switch1-GigabitEthernet1/0/6] port mux-vlan enable vlan 4

[Switch1-GigabitEthernet1/0/6] quit

 

3.2、配置接入层交换机的接口加入相应VLAN,略。

 

4、检查配置结果

4.1ServerHostBHostCHostDHostE二层流量互通。

4.2HostBHostC二层流量互通。

4.3HostDHostE二层流量不通。

4.4HostBHostCHostDHostE二层流量不通。

 

5、配置文件

5.1Switch1的配置文件

#

sysname Switch1

#

vlan batch 2 to 4

#

vlan 2

 mux-vlan

 subordinate separate 4

 subordinate group 3

#

interface Vlanif2                                                            

 ip address 192.168.100.100 255.255.255.0 

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 2

 port mux-vlan enable vlan 2

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk allow-pass vlan 3

 port mux-vlan enable vlan 3

#

interface GigabitEthernet1/0/4

 port link-type trunk

 port trunk allow-pass vlan 3

 port mux-vlan enable vlan 3

#

interface GigabitEthernet1/0/5

 port link-type trunk

 port trunk allow-pass vlan 4

 port mux-vlan enable vlan 4

#

interface GigabitEthernet1/0/6

 port link-type trunk

 port trunk allow-pass vlan 4

 port mux-vlan enable vlan 4

#

return

 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428互相学习。     
本文地址:http://www.023wg.com/vlan/156.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:重庆网管    圈哥