华为交换机MUX VLAN配置示例(接入层设备)
首页 > HuaWei > VLAN   作者:圈哥  2016年1月30日 16:38 星期六  热度:1623°  字号:   评论:0 条
时间:2016-1-30 16:38   热度:1623°  评论:0 条 

华为交换机MUX VLAN配置示例(接入层设备)

 

1、组网需求

       MUX-VLAN组网示例图.png

                      图1 MUX-VLAN组网示例图

如上图1所示,在企业网络中,企业所有员工都可以访问企业的服务器。但对于企业来说,希望企业内部部分员工之间可以互相交流,而部分员工之间是隔离的,不能够互相访问。

为了解决上述问题,可在连接终端的交换机上部署MUX VLAN(复合vlan)特性。MUX VLAN不但能够实现企业需求,同时也解决了VLAN ID紧缺问题,也便于网络管理者维护。

MUX vlan理论知识及配置教程可以参考这里:http://www.023wg.com/vlan/72.html

 

2、配置思路

2.1、配置主VLANMUX-VLAN功能。

2.2、配置Group-VLAN功能。

2.3、配置Separate-VLAN功能。

2.4、配置接口加入VLAN并使能MUX-VLAN功能。

 

3、操作步骤

3.1、配置MUX VLAN

# 创建VLAN2VLAN3VLAN4

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] vlan batch 2 3 4

 

# 配置MUX VLAN中的Group VLANSeparate VLAN

[Switch] vlan 2

[Switch-vlan2] mux-vlan

[Switch-vlan2] subordinate group 3

[Switch-vlan2] subordinate separate 4

[Switch-vlan2] quit

 

# 配置接口加入VLAN并使能MUX VLAN功能。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type access

[Switch-GigabitEthernet1/0/1] port default vlan 2

[Switch-GigabitEthernet1/0/1] port mux-vlan enable vlan 2

[Switch-GigabitEthernet1/0/1] quit

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port default vlan 3

[Switch-GigabitEthernet1/0/2] port mux-vlan enable vlan 3

[Switch-GigabitEthernet1/0/2] quit

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port default vlan 3

[Switch-GigabitEthernet1/0/3] port mux-vlan enable vlan 3

[Switch-GigabitEthernet1/0/3] quit

[Switch] interface gigabitethernet 1/0/4

[Switch-GigabitEthernet1/0/4] port link-type access

[Switch-GigabitEthernet1/0/4] port default vlan 4

[Switch-GigabitEthernet1/0/4] port mux-vlan enable vlan 4

[Switch-GigabitEthernet1/0/4] quit

[Switch] interface gigabitethernet 1/0/5

[Switch-GigabitEthernet1/0/5] port link-type access

[Switch-GigabitEthernet1/0/5] port default vlan 4

[Switch-GigabitEthernet1/0/5] port mux-vlan enable vlan 4

[Switch-GigabitEthernet1/0/5] quit

 

4、检查配置结果

4.1ServerHostBHostCHostDHostE在同一网段。

4.2ServerHostBHostCHostDHostE二层流量互通。

4.3HostBHostC二层流量互通。

4.4HostDHostE二层流量不通。

4.5HostBHostCHostDHostE二层流量不通。

 

5、配置文件

5.1Switch的配置文件

#

sysname Switch

#

vlan batch 2 to 4

#

vlan 2

 mux-vlan

 subordinate separate 4

 subordinate group 3

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 2

 port mux-vlan enable vlan 2

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 3

 port mux-vlan enable vlan 3

#

interface GigabitEthernet1/0/3

 port link-type access

 port default vlan 3

 port mux-vlan enable vlan 3

#

interface GigabitEthernet1/0/4

 port link-type access

 port default vlan 4

 port mux-vlan enable vlan 4

#

interface GigabitEthernet1/0/5

 port link-type access

 port default vlan 4

 port mux-vlan enable vlan 4

#

return

 您阅读这篇文章共花了: 
捐赠支持:如果觉得这篇文章对您有帮助,请“扫一扫”鼓励作者!
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428 互相学习。     
本文地址:http://www.023wg.com/vlan/155.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页    捐赠支持   
版权所有:重庆网管    圈哥