华为交换机VLAN聚合(超级vlan)配置示例
首页 > HuaWei > VLAN   作者:圈哥  2016年1月28日 17:02 星期四  字号:   评论:0 条
时间:2016-1-28 17:02   评论:0 条 

华为交换机VLAN聚合(超级vlan)配置示例

 

1、组网需求

       VLAN聚合组网图.png

                          图1 VLAN聚合组网图

如图1所示,某公司拥有多个部门且位于同一网段,为了提升业务安全性,将不同部门的用户划分到不同VLAN中。现由于业务需要,不同部门间的用户需要互通。

VLAN2VLAN3为不同部门,现需要实现不同VLAN间的用户可以互相访问。

可以在Switch上部署VLAN聚合,实现VLAN2VLAN3二层隔离、三层互通,同时VLAN2VLAN3采用同一个子网网段,节省了IP地址。

 

2、配置思路

2.1、把Switch接口加入到相应的sub-VLAN中,实现不同sub-VLAN间的二层隔离。

2.2、把sub-VLAN聚合为super-VLAN

2.3、配置VLANIF接口的IP地址。

2.4、配置super-VLANProxy ARP,实现sub-VLAN间的三层互通。

 

3、操作步骤

3.1、配置接口类型

# 配置接口GE1/0/1Access类型。接口GE1/0/2GE1/0/3GE1/0/4的配置与GE1/0/1相同,不再赘述。

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type access

[Switch-GigabitEthernet1/0/1] quit

 

#创建VLAN2并向VLAN2中加入GE1/0/1GE1/0/2

[Switch] vlan 2

[Switch-vlan2] port gigabitethernet 1/0/1 1/0/2

[Switch-vlan2] quit

 

#创建VLAN3并向VLAN3中加入GE1/0/3GE1/0/4

[Switch] vlan 3

[Switch-vlan3] port gigabitethernet 1/0/3 1/0/4

[Switch-vlan3] quit

 

3.2、配置VLAN4

# 配置super-VLAN

[Switch] vlan 4

[Switch-vlan4] aggregate-vlan

[Switch-vlan4] access-vlan 2 to 3

[Switch-vlan4] quit

 

# 配置VLANIF

[Switch] interface vlanif 4

[Switch-Vlanif4] ip address 10.1.1.12 255.255.255.0

[Switch-Vlanif4] quit

 

3.3、配置用户IP地址

分别为各用户配置IP地址,并使它们和VLAN4处于同一网段。

配置成功后,各用户与Switch之间可以相互ping通,但VLAN2的用户与VLAN3的用户间不可以相互ping通。还需要在Switch上配置Proxy ARP

 

3.4、配置Proxy ARP

[Switch] interface vlanif 4

[Switch-Vlanif4] arp-proxy inter-sub-vlan-proxy enable

[Switch-Vlanif4] quit

 

4、检查配置结果

配置完成后,VLAN2的用户与VLAN3的用户可以相互ping通。

 

5、配置文件

5.1Switch的配置文件

#

sysname Switch

#

vlan batch 2 to 4

#

vlan 4

 aggregate-vlan

 access-vlan 2 to 3

#

interface Vlanif4

 ip address 10.1.1.12 255.255.255.0

 arp-proxy inter-sub-vlan-proxy enable

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 2

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 2

#

interface GigabitEthernet1/0/3

 port link-type access

 port default vlan 3

#

interface GigabitEthernet1/0/4

 port link-type access

 port default vlan 3

#

return

 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428互相学习。     
本文地址:http://www.023wg.com/vlan/152.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:重庆网管    圈哥