VLAN之间通过VLAN Switch通信配置示例
首页 > HuaWei > VLAN   作者:圈哥  2016年1月27日 17:02 星期三  字号:   评论:0 条
时间:2016-1-27 17:02   评论:0 条 

VLAN之间通过VLAN Switch通信配置示例

 

1、组网需求

       VLAN之间通过VLAN Switch通信组网图.png

             图1 VLAN之间通过VLAN Switch通信组网图

如上图1所示,Switch的接口GE1/0/1GE1/0/2分别与SwitchASwitchB上行口相连,SwitchASwitchB的下行接口分别加入VLAN10VLAN20

要求VLAN10内的PCVLAN20内的PC能够互相访问。

 

2、配置思路

2.1、配置SwitchASwitchB的相关接口加入VLAN

2.2、配置SwitchVLAN Switch(vlan交换)功能。

       说明:

VLAN10VLAN20不能是Switch已经创建的全局VLAN,且接口GE1/0/1不能加入VLAN10GE1/0/2不能加入VLAN20,否则无法配置VLAN Switch

 

3、操作步骤

3.1、在SwitchA上创建VLAN10,配置SwitchA的接口GE1/0/1tagged方式加入VLAN10GE1/0/2GE1/0/3Access方式加入VLAN10SwitchB的配置与SwitchA类似,不再赘述。

<HUAWEI> system-view

[HUAWEI] sysname SwitchA

[SwitchA] vlan 10

[SwitchA-vlan10] quit

[SwitchA] interface gigabitethernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] port link-type hybrid

[SwitchA-GigabitEthernet1/0/1] port hybrid tagged vlan 10

[SwitchA-GigabitEthernet1/0/1] quit

[SwitchA] interface gigabitethernet 1/0/2

[SwitchA-GigabitEthernet1/0/2] port link-type access

[SwitchA-GigabitEthernet1/0/2] port default vlan 10

[SwitchA-GigabitEthernet1/0/2] quit

[SwitchA] interface gigabitethernet 1/0/3

[SwitchA-GigabitEthernet1/0/3] port link-type access

[SwitchA-GigabitEthernet1/0/3] port default vlan 10

[SwitchA-GigabitEthernet1/0/3] quit

 

3.2、配置Switch

# 配置SwitchVLAN Switch功能

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type hybrid

[Switch-GigabitEthernet1/0/1] quit

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type hybrid

[Switch-GigabitEthernet1/0/2] quit

[Switch] vlan-switch name1 interface gigabitethernet 1/0/1 vlan 10 interface gigabitethernet 1/0/2 switch-vlan 20

 

4、检查配置结果

配置完成后,VLAN10内的PCVLAN20PC能够相互访问。

 

5、配置文件

5.1SwitchA的配置文件。

#

sysname SwitchA

#

vlan batch 10

#

interface GigabitEthernet1/0/1

 port link-type hybrid

 port hybrid tagged vlan 10

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 10

#

interface GigabitEthernet1/0/3

 port link-type access

 port default vlan 10

#

Return

 

5.2SwitchB的配置文件。

#

sysname SwitchB

#

vlan batch 20

#

interface GigabitEthernet1/0/1

 port link-type hybrid

 port hybrid tagged vlan 20

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 20

#

interface GigabitEthernet1/0/3

 port link-type access

 port default vlan 20

#

Return

 

5.3Switch的配置文件。

#

sysname Switch

#

vlan-switch name1 interface GigabitEthernet1/0/1 vlan 10 interface GigabitEthernet1/0/2 switch-vlan 20

#

interface GigabitEthernet1/0/1

 port link-type hybrid

#

interface GigabitEthernet1/0/2

 port link-type hybrid

#

return

 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428互相学习。     
本文地址:http://www.023wg.com/vlan/150.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:重庆网管    圈哥