VLAN之间通过子接口通信配置示例
首页 > HuaWei > VLAN   作者:圈哥  2016年1月25日 17:14 星期一  字号:   评论:0 条
时间:2016-1-25 17:14   评论:0 条 

VLAN之间通过子接口通信配置示例

 

1、组网需求

       VLAN之间通过子接口通信组网图 .png

                 图1 配置VLAN间通过子接口通信组网图

如上图1所示,企业的不同部门拥有相同的业务,如上网、VoIP等业务,且各个部门中的用户位于不同的网段。目前存在不同的部门中相同的业务所属的VLAN不相同,现需要实现不同VLAN中的用户相互通信。

部门1和部门2中拥有相同的上网业务,但是属于不同的VLAN且位于不同的网段。现需要实现部门1与部门2的用户互通。

 

 

2、配置思路

2.1、配置各以太网接口的封装方式均采用802.1Q

2.2、配置各以太网接口所属的VLAN ID

2.3、配置各以太网接口的IP地址。

 

 

3、操作步骤

配置SwitchA的上行接口以tagged方式加入VLAN10,用户侧接口以untagged方式加入VLAN10SwitchB的上行接口以tagged方式加入VLAN20,用户侧接口以untagged方式加入VLAN20

 

3.1、配置Switch上连接SwitchA的接口

# 创建并配置以太网子接口GE1/0/1.1

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] interface gigabitethernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type hybrid

[Switch-GigabitEthernet1/0/1] quit

[Switch] interface gigabitethernet1/0/1.1

[Switch-GigabitEthernet1/0/1.1] dot1q termination vid 10

[Switch-GigabitEthernet1/0/1.1] ip address 10.10.10.1 24

[Switch-GigabitEthernet1/0/1.1] arp broadcast enable

[Switch-GigabitEthernet1/0/1.1] quit

 

3.2、配置Switch上连接SwitchB的接口

# 创建并配置以太网子接口GE1/0/2.1

[Switch] interface gigabitethernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type hybrid

[Switch-GigabitEthernet1/0/2] quit

[Switch] interface gigabitethernet 1/0/2.1

[Switch-GigabitEthernet1/0/2.1] dot1q termination vid 20

[Switch-GigabitEthernet1/0/2.1] ip address 10.10.20.1 24

[Switch-GigabitEthernet1/0/2.1] arp broadcast enable

[Switch-GigabitEthernet1/0/2.1] quit

 

 

4、检查配置结果

VLAN10中的PC1上配置缺省网关为GE1/0/1.1接口的IP地址10.10.10.1/24

VLAN20中的PC2上配置缺省网关为GE1/0/2.1接口的IP地址10.10.20.1/24

配置完成后,VLAN10内的PC1VLAN20内的PC2能够互相访问。

 

 

5、配置文件

以下仅给出Switch的配置文件。

#

sysname Switch

#

interface GigabitEthernet1/0/1

 port link-type hybrid

#

interface GigabitEthernet1/0/1.1

 dot1q termination vid 10

 ip address 10.10.10.1 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet1/0/2

 port link-type hybrid

#

interface GigabitEthernet1/0/2.1

 dot1q termination vid 20

 ip address 10.10.20.1 255.255.255.0

 arp broadcast enable

#

return

 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428互相学习。     
本文地址:http://www.023wg.com/vlan/146.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:重庆网管    圈哥