VLANIF与OSPF跨越三层网络通信配置示例
首页 > HuaWei > VLAN   作者:圈哥  2016年1月23日 17:10 星期六  热度:892°  字号:   评论:0 条
时间:2016-1-23 17:10   热度:892°  评论:0 条 

VLANIFOSPF跨越三层网络通信配置示例

 

1、组网需求

       VLANIF与OSPF跨越三层网络通信组网图 .png

           图1 配置通过VLANIF接口跨越三层网络通信组网图

如上图1所示,SwitchASwitchB分别下挂VLAN10的二层网络,SwitchASwitchB之间通过三层网络互通,三层网络采用OSPF协议。

要求两个二层网络的PC实现二层隔离三层互通。

 

 

2、配置思路

2.1、配置接口所属的VLAN,允许VLAN通过当前接口。

2.2、配置VLANIF接口的IP地址,实现三层互通。

2.3、配置OSPF基本功能,实现路由互通。

 

 

3、操作步骤

3.1、配置SwitchA

# 创建VLAN10VLAN30

<HUAWEI> system-view

[HUAWEI] sysname SwitchA

[SwitchA] vlan batch 10 30

 

# 配置接口GE1/0/1加入VLAN 10GE1/0/2加入VLAN 30

[SwitchA] interface gigabitethernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] port link-type trunk

[SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10

[SwitchA-GigabitEthernet1/0/1] quit

[SwitchA] interface gigabitethernet 1/0/2

[SwitchA-GigabitEthernet1/0/2] port link-type trunk

[SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 30

[SwitchA-GigabitEthernet1/0/2] quit

 

# 配置VLANIF10IP地址为10.10.10.1/24VLANIF30IP地址为10.10.30.1/24

[SwitchA] interface vlanif 10

[SwitchA-Vlanif10] ip address 10.10.10.1 24

[SwitchA-Vlanif10] quit

[SwitchA] interface vlanif 30

[SwitchA-Vlanif30] ip address 10.10.30.1 24

[SwitchA-Vlanif30] quit

 

# 配置OSPF基本功能

[SwitchA] router id 1.1.1.1

[SwitchA] ospf

[SwitchA-ospf-1] area 0

[SwitchA-ospf-1-area-0.0.0.0] network 10.10.10.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 10.10.30.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] quit

 

3.2、配置SwitchB

# 创建VLAN10VLAN30

<HUAWEI> system-view

[HUAWEI] sysname SwitchB

[SwitchB] vlan batch 10 30

 

# 配置接口GE1/0/2加入VLAN 10GE1/0/1加入VLAN 30

[SwitchB] interface gigabitethernet 1/0/2

[SwitchB-GigabitEthernet1/0/2] port link-type trunk

[SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 10

[SwitchB-GigabitEthernet1/0/2] quit

[SwitchB] interface gigabitethernet 1/0/1

[SwitchB-GigabitEthernet1/0/1] port link-type trunk

[SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 30

[SwitchB-GigabitEthernet1/0/1] quit

 

# 配置VLANIF10IP地址为10.10.20.1/24VLANIF30IP地址为10.10.30.2/24

[SwitchB] interface vlanif 10

[SwitchB-Vlanif10] ip address 10.10.20.1 24

[SwitchB-Vlanif10] quit

[SwitchB] interface vlanif 30

[SwitchB-Vlanif30] ip address 10.10.30.2 24

[SwitchB-Vlanif30] quit

 

# 配置OSPF基本功能

[SwitchB] router id 2.2.2.2

[SwitchB] ospf

[SwitchB-ospf-1] area 0

[SwitchB-ospf-1-area-0.0.0.0] network 10.10.20.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] network 10.10.30.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] quit

 

 

4、检查配置结果

SwitchA下挂的二层网络中PC上配置缺省网关为VLANIF10接口的IP地址10.10.10.1/24

SwitchB下挂的二层网络中PC上配置缺省网关为VLANIF10接口的IP地址10.10.20.1/24

配置完成后,两个二层网络的PC实现二层隔离三层互通。

 

 

5、配置文件

5.1SwitchA的配置文件。

#

sysname SwitchA

#

router id 1.1.1.1

#

vlan batch 10 30

#

interface Vlanif10

 ip address 10.10.10.1 255.255.255.0

#

interface Vlanif30

 ip address 10.10.30.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 30

#

ospf 1

 area 0.0.0.0

  network 10.10.10.0 0.0.0.255

  network 10.10.30.0 0.0.0.255

#

Return

 

5.2SwitchB的配置文件。

#

sysname SwitchB

#

router id 2.2.2.2

#

vlan batch 10 30

#

interface Vlanif10

 ip address 10.10.20.1 255.255.255.0

#

interface Vlanif30

 ip address 10.10.30.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 30

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 10

#

ospf 1

 area 0.0.0.0

  network 10.10.20.0 0.0.0.255

  network 10.10.30.0 0.0.0.255

#

return

 您阅读这篇文章共花了: 
捐赠支持:如果觉得这篇文章对您有帮助,请“扫一扫”鼓励作者!
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428 互相学习。     
本文地址:http://www.023wg.com/vlan/142.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页    捐赠支持   
版权所有:重庆网管    圈哥