VLAN间通过VLANIF通信配置示例
首页 > HuaWei > VLAN   作者:圈哥  2016年1月22日 16:58 星期五  热度:1444°  字号:   评论:0 条
时间:2016-1-22 16:58   热度:1444°  评论:0 条 

VLAN间通过VLANIF通信配置示例

 

1、组网需求

       VLAN间通过VLANIF接口通信示例图 .png

           图1 配置VLAN间通过VLANIF接口通信组网图

如图1所示,企业的不同用户拥有相同的业务,且位于不同的网段。现在相同业务的用户所属的VLAN不相同,需要实现不同VLAN中的用户相互通信。

User1User2中拥有相同的业务,但是属于不同的VLAN且位于不同的网段。现需要实现User1User2互通。

 

2、配置思路

2.1、创建VLAN,确定用户所属的VLAN

2.2、配置接口加入VLAN,允许用户所属的VLAN通过当前接口。

2.3、创建VLANIF接口并配置IP地址,实现三层互通。

为了成功实现VLAN间互通,VLAN内主机的缺省网关必须是对应VLANIF接口的IP地址。

 

3、操作步骤

配置Switch

# 创建VLAN

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] vlan batch 10 20

 

# 配置接口加入VLAN

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type access

[Switch-GigabitEthernet1/0/1] port default vlan 10

[Switch-GigabitEthernet1/0/1] quit

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port default vlan 20

[Switch-GigabitEthernet1/0/2] quit

 

# 配置VLANIF接口的IP地址

[Switch] interface vlanif 10

[Switch-Vlanif10] ip address 10.10.10.2 24

[Switch-Vlanif10] quit

[Switch] interface vlanif 20

[Switch-Vlanif20] ip address 10.10.20.2 24

[Switch-Vlanif20] quit

 

4、检查配置结果

VLAN10中的User1主机上配置IP地址为10.10.10.3/24,缺省网关为VLANIF10接口的IP地址10.10.10.2/24

VLAN20中的User2主机上配置IP地址为10.10.20.3/24,缺省网关为VLANIF20接口的IP地址10.10.20.2/24

配置完成后,VLAN10内的User1VLAN20内的User2能够相互访问。

  

5、配置文件

Switch的配置文件

#

sysname Switch

#

vlan batch 10 20

#

interface Vlanif10

 ip address 10.10.10.2 255.255.255.0

#

interface Vlanif20

 ip address 10.10.20.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 10

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 20

#

return

 您阅读这篇文章共花了: 
捐赠支持:如果觉得这篇文章对您有帮助,请“扫一扫”鼓励作者!
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428 互相学习。     
本文地址:http://www.023wg.com/vlan/138.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页    捐赠支持   
版权所有:重庆网管    圈哥