基于IP子网划分VLAN配置示例
首页 > HuaWei > VLAN   作者:浙江思唯网络  2016年1月19日 17:16 星期二  字号:   评论:0 条
时间:2016-1-19 17:16   评论:0 条 

基于IP子网划分VLAN配置示例

1、组网需求

            基于IP子网划分VLAN组网图 .png

              图1 基于IP子网划分VLAN组网图

如图1所示,某企业拥有多种业务,如IPTVVoIPInternet等,每种业务使用的IP地址网段各不相同。为了便于管理,现需要将同一种类型业务划分到同一VLAN中,不同类型的业务划分到不同VLAN中。

Switch接收到用户报文有数据、IPTV、语音等多种业务,用户设备的IP地址网段各不相同。现需要将不同类型的业务划分到不同的VLAN中,通过不同的VLAN ID分流到不同的远端服务器上以实现业务互通。

 

2、配置思路

2.1、创建VLAN,确定每种业务所属的VLAN

2.2、关联IP子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN

2.3、配置接口加入VLAN,实现基于IP子网的VLAN通过当前接口。

2.4、使能基于IP子网划分VLAN

 

3、操作步骤

3.1、创建VLAN

# Switch上创建VLAN100VLAN200VLAN300

<HUAWEI> system-view
[HUAWEI] sysname Switch
[Switch] vlan batch 100 200 300

3.2、配置接口

# Switch上配置接口GE1/0/5GE1/0/6GE1/0/7Hybrid类型,分别以untagged方式加入VLAN100VLAN200VLAN300。并使能基于IP子网划分VLAN功能。

[Switch] interface gigabitethernet 1/0/5
[Switch-GigabitEthernet1/0/5] port link-type hybrid
[Switch-GigabitEthernet1/0/5] port hybrid untagged vlan 100
[Switch-GigabitEthernet1/0/5] ip-subnet-vlan enable
[Switch-GigabitEthernet1/0/5] quit
[Switch] interface gigabitethernet 1/0/6
[Switch-GigabitEthernet1/0/6] port link-type hybrid
[Switch-GigabitEthernet1/0/6] port hybrid untagged vlan 200
[Switch-GigabitEthernet1/0/6] ip-subnet-vlan enable
[Switch-GigabitEthernet1/0/6] quit
[Switch] interface gigabitethernet 1/0/7
[Switch-GigabitEthernet1/0/7] port link-type hybrid
[Switch-GigabitEthernet1/0/7] port hybrid untagged vlan 300
[Switch-GigabitEthernet1/0/7] ip-subnet-vlan enable
[Switch-GigabitEthernet1/0/7] quit

# Switch上配置接口GE1/0/2加入VLAN100

[Switch] interface gigabitethernet 1/0/2
[Switch-GigabitEthernet1/0/2] port link-type trunk
[Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 100
[Switch-GigabitEthernet1/0/2] quit

# Switch上配置接口GE1/0/3加入VLAN200

[Switch] interface gigabitethernet 1/0/3
[Switch-GigabitEthernet1/0/3] port link-type trunk
[Switch-GigabitEthernet1/0/3] port trunk allow-pass vlan 200
[Switch-GigabitEthernet1/0/3] quit

# Switch上配置接口GE1/0/4加入VLAN300

[Switch] interface gigabitethernet 1/0/4
[Switch-GigabitEthernet1/0/4] port link-type trunk
[Switch-GigabitEthernet1/0/4] port trunk allow-pass vlan 300
[Switch-GigabitEthernet1/0/4] quit

3.3、配置基于IP子网划分VLAN

# Switch上配置VLAN100IP地址192.168.1.2/24关联,优先级为2

[Switch] vlan 100
[Switch-vlan100] ip-subnet-vlan 1 ip 192.168.1.2 24 priority 2
[Switch-vlan100] quit

# Switch上配置VLAN200IP地址192.168.2.2/24关联,优先级为3

[Switch] vlan 200
[Switch-vlan200] ip-subnet-vlan 1 ip 192.168.2.2 24 priority 3
[Switch-vlan200] quit

# Switch上配置VLAN300IP地址192.168.3.2/24关联,优先级为4

[Switch] vlan 300
[Switch-vlan300] ip-subnet-vlan 1 ip 192.168.3.2 24 priority 4
[Switch-vlan300] quit

4、验证配置结果

Switch上执行以下命令,显示信息如下:

[Switch] display ip-subnet-vlan vlan all
----------------------------------------------------------------
 Vlan    Index   IpAddress           SubnetMask          Priority
 ----------------------------------------------------------------
 100     1       192.168.1.2         255.255.255.0       2
 200     1       192.168.2.2         255.255.255.0       3
 300     1       192.168.3.2         255.255.255.0       4
 ----------------------------------------------------------------
 ip-subnet-vlan count: 3                  total count: 3

5、配置文件

5.1Switch的配置文件

#
sysname Switch
#
vlan batch 100 200 300
#
vlan 100
 ip-subnet-vlan 1 ip 192.168.1.2 255.255.255.0 priority 2
vlan 200
 ip-subnet-vlan 1 ip 192.168.2.2 255.255.255.0 priority 3
vlan 300
 ip-subnet-vlan 1 ip 192.168.3.2 255.255.255.0 priority 4
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 100
#
interface GigabitEthernet1/0/3
 port link-type trunk
 port trunk allow-pass vlan 200
#
interface GigabitEthernet1/0/4
 port link-type trunk
 port trunk allow-pass vlan 300
#
interface GigabitEthernet1/0/5
 port link-type hybrid
 port hybrid untagged vlan 100
 ip-subnet-vlan enable
#
interface GigabitEthernet1/0/6
 port link-type hybrid
 port hybrid untagged vlan 200
 ip-subnet-vlan enable
#
interface GigabitEthernet1/0/7
 port link-type hybrid
 port hybrid untagged vlan 300
 ip-subnet-vlan enable
#
return


 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:859273036 互相学习。     
本文地址:http://www.023wg.com/vlan/132.html
版权声明:若无注明,本文皆为“思唯网络教育博客”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:思唯网络教育博客    浙江思唯网络