基于接口划分VLAN配置示例(静态配置链路类型)
首页 > HuaWei > VLAN   作者:杭州清默网络  2016年1月16日 15:44 星期六  字号:   评论:0 条
时间:2016-1-16 15:44   评论:0 条 

基于接口划分VLAN配置示例(静态配置链路类型)

 

1、组网需求

    基于接口划分VLAN组网图 .png

                                     图1 基于接口划分VLAN组网图

如上图1所示,某企业的交换机连接有很多用户,且相同业务用户通过不同的设备接入企业网络。

为了通信的安全性,同时为了避免广播风暴,企业希望业务相同用户之间可以互相访问,业务不同用户不能直接访问。

可以在交换机上配置基于接口划分VLAN,把业务相同的用户连接的接口划分到同一VLAN。这样属于不同VLAN的用户不能直接进行二层通信,同一VLAN内的用户可以直接互相通信。

 

2、配置思路

采用如下的思路配置VLAN

创建VLAN并将连接用户的接口加入VLAN,实现不同业务用户之间的二层流量隔离。

配置SwitchASwitchB之间的链路类型及通过的VLAN,实现相同业务用户通过SwitchASwitchB通信。

 

3、操作步骤

3.1、在SwitchA创建VLAN2VLAN3,并将连接用户的接口分别加入VLANSwitchB的配置与SwitchA类似,不再赘述。


<HUAWEI> system-view

[HUAWEI] sysname SwitchA

[SwitchA] vlan batch 2 3

[SwitchA] interface gigabitethernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] port link-type access

[SwitchA-GigabitEthernet1/0/1] port default vlan 2

[SwitchA-GigabitEthernet1/0/1] quit

[SwitchA] interface gigabitethernet 1/0/2

[SwitchA-GigabitEthernet1/0/2] port link-type access

[SwitchA-GigabitEthernet1/0/2] port default vlan 3

[SwitchA-GigabitEthernet1/0/2] quit

 

3.2、配置SwitchA上与SwitchB连接的接口类型及通过的VLANSwitchB的配置与SwitchA类似,不再赘述。

[SwitchA] interface gigabitethernet 1/0/3

[SwitchA-GigabitEthernet1/0/3] port link-type trunk

[SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 2 3

 

3.3、验证配置结果

User1User2配置在一个网段,比如192.168.100.0/24;将User3User4配置在一个网段,比如192.168.200.0/24

User1和User2能够互相ping通,但是均不能pingUser3User4User3User4能够互相ping通,但是均不能pingUser1User2

 

4、配置文件

4.1、SwitchA的配置文件

#

sysname SwitchA

#

vlan batch 2 to 3

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 2

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 3

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk allow-pass vlan 2 to 3

#

return


4.2、SwitchB的配置文件

#

sysname SwitchB

#

vlan batch 2 to 3

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 2

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 3 

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk allow-pass vlan 2 to 3

#

Return

 

本文来自华为官方配置文档

 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:647682417 互相学习。     
本文地址:http://www.023wg.com/vlan/126.html
版权声明:若无注明,本文皆为“杭州清默网络”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:杭州清默网络    杭州清默网络