华为OSPF 路由GR特性配置示例
首页 > HuaWei > 路由配置   作者:杭州清默网络  2016年3月2日 17:04 星期三  字号:   评论:0 条
时间:2016-3-2 17:04   评论:0 条 

华为OSPF 路由GR特性配置示例

1、组网需求

    华为OSPF路由 GR特效组网示例.png

                    华为OSPF路由 GR特效组网示例

    如图1所示,三台设备之间运行OSPF协议,整个OSPF网络被划分为Area0Area1两个区域。

    现要求在SwitchC上运行的OSPF协议重启过程中不影响数据的正常转发。

 

2、配置思路

2.1、在各交换机上配置OSPF基本功能,实现OSPF网络的基本互通。

2.2、 在SwitchASwitchC上使能Opaque LSA功能,实现OSPF通过Type9 LSA支持OSPF GR

2.3、在SwitchASwitchC上配置GR功能,实现当OSPF协议重启时保证数据正常转发。

 

3、操作步骤

3.1、配置各接口所属的VLAN

# 配置SwitchASwitchBSwitchC的配置与SwitchA类似。

<HUAWEI> system-view

[HUAWEI] sysname SwitchA

[SwitchA] vlan batch 10 20

[SwitchA] interface gigabitethernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] port link-type trunk

[SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10

[SwitchA-GigabitEthernet1/0/1] quit

[SwitchA] interface gigabitethernet 1/0/2

[SwitchA-GigabitEthernet1/0/2] port link-type trunk

[SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 20

[SwitchA-GigabitEthernet1/0/2] quit

 

3.2、配置各VLANIF接口的IP地址

# 配置SwitchASwitchBSwitchC的配置与SwitchA类似。

[SwitchA] interface vlanif 10

[SwitchA-Vlanif10] ip address 192.168.0.1 24

[SwitchA-Vlanif10] quit

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] ip address 192.168.1.1 24

[SwitchA-Vlanif20] quit

 

3.3、配置OSPF基本功能

# 配置SwitchA

[SwitchA] ospf 1 router-id 10.1.1.1

[SwitchA-ospf-1] area 0

[SwitchA-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] quit

[SwitchA-ospf-1] area 1

[SwitchA-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.1] quit

[SwitchA-ospf-1] quit

 

# 配置SwitchB

[SwitchB] ospf 1 router-id 10.2.2.2

[SwitchB-ospf-1] area 0

[SwitchB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] quit

[SwitchB-ospf-1] quit

 

# 配置SwitchC

[SwitchC] ospf 1 router-id 10.3.3.3

[SwitchC-ospf-1] area 1

[SwitchC-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255

[SwitchC-ospf-1-area-0.0.0.1] quit

[SwitchC-ospf-1] quit

 

3.4、使能Opaque-LSA功能

# 配置SwitchA

[SwitchA] ospf 1

[SwitchA-ospf-1] opaque-capability enable

[SwitchA-ospf-1] quit

 

# 配置SwitchC

[SwitchC] ospf 1

[SwitchC-ospf-1] opaque-capability enable

[SwitchC-ospf-1] quit

 

3.5、配置OSPF GR特性

# 配置SwitchA

[SwitchA] ospf 1

[SwitchA-ospf-1] graceful-restart

[SwitchA-ospf-1] return

 

# 配置SwitchC

[SwitchC] ospf 1

[SwitchC-ospf-1] graceful-restart

[SwitchC-ospf-1] return

 

4、验证配置结果

# 查看SwitchCGR状态。

<SwitchC> display ospf graceful-restart

 

          OSPF Process 1 with Router ID 10.3.3.3

 Graceful-restart capability     : enabled

 Graceful-restart support        : planned and un-planned, totally

 Helper-policy support           : planned and un-planned, strict lsa check

 Current GR state                : normal

 Graceful-restart period         : 120 seconds

 

 Number of neighbors under helper:

  Normal neighbors    : 0

  Virtual neighbors   : 0

  Sham-link neighbors : 0

  Total neighbors     : 0

 

 Number of restarting neighbors : 0

 

 Last exit reason:

  On graceful restart : none

  On Helper           : none

 

# SwitchA查看邻居状态。

<SwitchA> display ospf peer

 

          OSPF Process 1 with Router ID 10.1.1.1

                    Neighbors

 

 Area 0.0.0.0 interface 192.168.0.1(Vlanif10)'s neighbors

 Router ID: 10.2.2.2          Address: 192.168.0.2      GR State: Normal    

   State: Full  Mode:Nbr is  Master  Priority: 1

   DR: 192.168.0.2  BDR: 192.168.0.1  MTU: 0   

   Dead timer due in 40  sec

   Retrans timer interval: 5

   Neighbor is up for 00:04:28    

   Authentication Sequence: [ 0 ]

 

                    Neighbors

 

 Area 0.0.0.1 interface 192.168.1.1(Vlanif20)'s neighbors

 Router ID: 10.3.3.3          Address: 192.168.1.2      GR State: Normal   

   State: Full  Mode:Nbr is  Master  Priority: 1

   DR: 192.168.1.1  BDR: 192.168.1.2  MTU: 0   

   Dead timer due in 36  sec

   Retrans timer interval: 5

   Neighbor is up for 00:00:00    

   Authentication Sequence: [ 0 ]

   可以看到,SwitchAOSPF邻居处于Full状态,GR的状态是Normal

 

# 平滑重启SwitchCOSPF进程。

<SwitchC> reset ospf process graceful-restart

 

# SwitchA查看邻居状态。

<SwitchA> display ospf peer

 

          OSPF Process 1 with Router ID 10.1.1.1

                    Neighbors

 

 Area 0.0.0.0 interface 192.168.0.1(Vlanif10)'s neighbors

 Router ID: 10.2.2.2          Address: 192.168.0.2      GR State: Normal    

   State: Full  Mode:Nbr is  Master  Priority: 1

   DR: 192.168.0.2  BDR: 192.168.0.1  MTU: 0   

   Dead timer due in 40  sec

   Retrans timer interval: 5

   Neighbor is up for 00:04:28    

   Authentication Sequence: [ 0 ]

 

                    Neighbors

 

 Area 0.0.0.1 interface 192.168.1.1(Vlanif20)'s neighbors

 Router ID: 10.3.3.3          Address: 192.168.1.2      GR State: Doing GR  

   State: Full  Mode:Nbr is  Slave  Priority: 1

   DR: 192.168.1.1  BDR: 192.168.1.2  MTU: 0   

   Dead timer due in 36  sec

   Retrans timer interval: 5

   Neighbor is up for 00:00:00    

   Authentication Sequence: [ 0 ]

    可以看到,SwitchASwitchC邻居关系继续保持为Full状态,不受SwitchCOSPF进程平滑重启的影响。

 

5、配置文件

5.1SwitchA的配置文件

#

sysname SwitchA

#

vlan batch 10 20

#

interface Vlanif10

 ip address 192.168.0.1 255.255.255.0

#

interface Vlanif20

 ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 20

#

ospf 1 router-id 10.1.1.1

 opaque-capability enable

 graceful-restart

 area 0.0.0.0

  network 192.168.0.0 0.0.0.255

 area 0.0.0.1

  network 192.168.1.0 0.0.0.255

#

return

 

5.2SwitchB的配置文件

#

sysname SwitchB

#

vlan batch 10

#

interface Vlanif10

 ip address 192.168.0.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

ospf 1 router-id 10.2.2.2

 area 0.0.0.0

  network 192.168.0.0 0.0.0.255

#

return

 

5.3SwitchC的配置文件

#

sysname SwitchC

#

vlan batch 20

#

interface Vlanif20

 ip address 192.168.1.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 20

#

ospf 1 router-id 10.3.3.3

 opaque-capability enable

 graceful-restart

 area 0.0.0.1

  network 192.168.1.0 0.0.0.255

#

return

 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:647682417 互相学习。     
本文地址:http://www.023wg.com/lypz/197.html
版权声明:若无注明,本文皆为“杭州清默网络”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:杭州清默网络    杭州清默网络