华为OSPF路由负载分担配置示例
首页 > HuaWei > 路由配置   作者:杭州清默网络  2016年3月1日 17:12 星期二  字号:   评论:0 条
时间:2016-3-1 17:12   评论:0 条 

华为OSPF路由负载分担配置示例

1、组网需求

     OSPF负载分担组网示例图.png

                         1 OSPF负载分担组网示例图

    如图1所示,OSPF网络中有四台交换机,同属于区域0。要求配置负载分担,使得SwitchA流量,可以分别通过SwitchBSwitchC送到SwitchD


2、配置思路

2.1、在各交换机上配置OSPF基本功能,实现OSPF网络的基本互通。

2.2、在SwitchA配置负载分担,实现负载均衡的目的。


3、操作步骤

3.1、配置各接口所属VLAN

# 配置SwitchASwitchBSwitchCSwitchD的配置与SwitchA类似。

<HUAWEI> system-view

[HUAWEI] sysname SwitchA

[SwitchA] vlan batch 10 20 50

[SwitchA] interface gigabitethernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] port link-type trunk

[SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10

[SwitchA-GigabitEthernet1/0/1] quit

[SwitchA] interface gigabitethernet 1/0/2

[SwitchA-GigabitEthernet1/0/2] port link-type trunk

[SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 20

[SwitchA-GigabitEthernet1/0/2] quit

[SwitchA] interface gigabitethernet 1/0/3

[SwitchA-GigabitEthernet1/0/3] port link-type trunk

[SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 50

[SwitchA-GigabitEthernet1/0/3] quit

 

3.2、配置各VLANIF接口的IP地址

# 配置SwitchASwitchBSwitchCSwitchD的配置与SwitchA类似。

[SwitchA] interface vlanif 10

[SwitchA-Vlanif10] ip address 10.1.1.1 24

[SwitchA-Vlanif10] quit

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] ip address 10.1.2.1 24

[SwitchA-Vlanif20] quit

[SwitchA] interface vlanif 50

[SwitchA-Vlanif50] ip address 172.16.1.1 24

[SwitchA-Vlanif50] quit

 

3.3、配置OSPF基本功能

# 配置SwitchA

[SwitchA] ospf 1 router-id 10.10.10.1

[SwitchA-ospf-1] area 0

[SwitchA-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] quit

[SwitchA-ospf-1] quit

 

# 配置SwitchB

[SwitchB] ospf 1 router-id 10.10.10.2

[SwitchB-ospf-1] area 0

[SwitchB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.0] quit

[SwitchB-ospf-1] quit

 

# 配置SwitchC

[SwitchC] ospf 1 router-id 10.10.10.3

[SwitchC-ospf-1] area 0

[SwitchC-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255

[SwitchC-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255

[SwitchC-ospf-1-area-0.0.0.0] quit

[SwitchC-ospf-1] quit

 

# 配置SwitchD

[SwitchD] ospf 1 router-id 10.10.10.4

[SwitchD-ospf-1] area 0

[SwitchD-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255

[SwitchD-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255

[SwitchD-ospf-1-area-0.0.0.0] network 172.17.1.0 0.0.0.255

[SwitchD-ospf-1-area-0.0.0.0] quit

[SwitchD-ospf-1] quit

 

# 查看SwitchA的路由表。

[SwitchA] display ip routing-table

Route Flags: R - relay, D - download to fib

----------------------------------------------------------------------------

Routing Tables: Public

         Destinations : 11       Routes : 12

 

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

 

       10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10

       10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10

       10.1.2.0/24  Direct  0    0           D   10.1.2.1        Vlanif20

       10.1.2.1/32  Direct  0    0           D   127.0.0.1       Vlanif20

      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0

      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0

     172.16.1.0/24  Direct  0    0           D   172.16.1.1      Vlanif50

     172.16.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif50

     172.17.1.0/24  OSPF    10   3           D   10.1.1.2        Vlanif10

                    OSPF    10   3           D   10.1.2.2        Vlanif20

    192.168.0.0/24  OSPF    10   2           D   10.1.1.2        Vlanif10

    192.168.1.0/24  OSPF    10   2           D   10.1.2.2        Vlanif20

    从路由表可以看出,由于最大等价路由条数的缺省值为16,因此SwitchA的两个下一跳10.1.1.2SwitchB)和10.1.2.2SwitchC)均成为有效路由。

 

3.4、在SwitchA上配置等价路由优先级

如果不希望SwitchBSwitchC形成负载分担,可以配置等价路由优先级,指定下一跳。

[SwitchA] ospf 1

[SwitchA-ospf-1] nexthop 10.1.2.2 weight 1

[SwitchA-ospf-1] quit

 

# 查看SwitchA的路由表

[SwitchA] display ip routing-table

Route Flags: R - relay, D - download to fib

--------------------------------------------------------------------------------

Routing Tables: Public

         Destinations : 11       Routes : 11

 

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

       10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10

       10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10

       10.1.2.0/24  Direct  0    0           D   10.1.2.1        Vlanif20

       10.1.2.1/32  Direct  0    0           D   127.0.0.1       Vlanif20

      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0

      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0

     172.16.1.0/24  Direct  0    0           D   172.16.1.1      Vlanif50

     172.16.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif50

     172.17.1.0/24  OSPF    10   3           D   10.1.2.2        Vlanif20

    192.168.0.0/24  OSPF    10   2           D   10.1.1.2        Vlanif10

    192.168.1.0/24  OSPF    10   2           D   10.1.2.2        Vlanif20

    从路由表中可以看出,当配置等价路由的优先级后,由于下一跳为10.1.2.2SwitchC)的优先级(权值为1)高于下一跳为10.1.1.2SwitchB)的优先级,所以OSPF优先选择下一跳为10.1.2.2为唯一最优路由。


4、配置文件 

4.1SwitchA的配置文件

#

sysname SwitchA

#

vlan batch 10 20 50

#

interface Vlanif10

 ip address 10.1.1.1 255.255.255.0

#

interface Vlanif20

 ip address 10.1.2.1 255.255.255.0

#

interface Vlanif50

 ip address 172.16.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 20

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk allow-pass vlan 50

#

ospf 1 router-id 10.10.10.1

 nexthop 10.1.2.2 weight 1

 area 0.0.0.0

  network 10.1.1.0 0.0.0.255

  network 10.1.2.0 0.0.0.255

  network 172.16.1.0 0.0.0.255

#

return

 

4.2SwitchB的配置文件

#

sysname SwitchB

#

vlan batch 10 30

#

interface Vlanif10

 ip address 10.1.1.2 255.255.255.0

#

interface Vlanif30

 ip address 192.168.0.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 30

#

ospf 1 router-id 10.10.10.2

 area 0.0.0.0

  network 10.1.1.0 0.0.0.255

  network 192.168.0.0 0.0.0.255

#

return

 

4.3SwitchC的配置文件

#

sysname SwitchC

#

vlan batch 20 40

#

interface Vlanif20

 ip address 10.1.2.2 255.255.255.0

#

interface Vlanif40

 ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 20

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 40

#

ospf 1 router-id 10.10.10.3

 area 0.0.0.0

  network 10.1.2.0 0.0.0.255

  network 192.168.1.0 0.0.0.255

#

return

 

4.4SwitchD的配置文件

#

sysname SwitchD

#

vlan batch 30 40 60

#

interface Vlanif30

 ip address 192.168.0.2 255.255.255.0

#

interface Vlanif40

 ip address 192.168.1.2 255.255.255.0

#

interface Vlanif60

 ip address 172.17.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 30

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 40

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk allow-pass vlan 60

#

ospf 1 router-id 10.10.10.4

 area 0.0.0.0

  network 172.17.1.0 0.0.0.255

  network 192.168.0.0 0.0.0.255

  network 192.168.1.0 0.0.0.255

#

return

 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:647682417 互相学习。     
本文地址:http://www.023wg.com/lypz/195.html
版权声明:若无注明,本文皆为“杭州清默网络”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:杭州清默网络    杭州清默网络