华为OSPF路由中虚连接(vlink-peer)配置示例
首页 > HuaWei > 路由配置   作者:杭州清默网络  2016年2月26日 17:02 星期五  字号:   评论:0 条
时间:2016-2-26 17:02   评论:0 条 

华为OSPF路由中虚连接(vlink-peer)配置示例

1、组网需求

    OSPF虚连接(vlink-peer)的组网示例图.png

                     1 OSPF虚连接(vlink-peer)的组网示例图

    如图1所示,原OSPF网络被划分为Area0Area1两个区域。

    由于现网限制,现需要以SwitchBABR来规划一个区域Area2加入整个OSPF网络。

 

2、配置思路

    2.1、在各交换机上配置OSPF基本功能,实现Area0Area1以及Area2内部路由互通。

    2.2、在SwitchASwitchB上配置虚连接(vlink-peer),实现Area2与其他区域路由互通。

 

3、操作步骤

3.1、配置各接口所属的VLAN

# 配置SwitchASwitchBSwitchCSwitchD的配置与SwitchA类似。

<HUAWEI> system-view

[HUAWEI] sysname SwitchA

[SwitchA] vlan batch 10 20

[SwitchA] interface gigabitethernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] port link-type trunk

[SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10

[SwitchA-GigabitEthernet1/0/1] quit

[SwitchA] interface gigabitethernet 1/0/2

[SwitchA-GigabitEthernet1/0/2] port link-type trunk

[SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 20

[SwitchA-GigabitEthernet1/0/2] quit

 

3.2、配置各VLANIF接口的IP地址

# 配置SwitchASwitchBSwitchCSwitchD的配置与SwitchA类似。

[SwitchA] interface vlanif 10

[SwitchA-Vlanif10] ip address 10.1.1.1 24

[SwitchA-Vlanif10] quit

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] ip address 192.168.1.1 24

[SwitchA-Vlanif20] quit

 

3.3、配置OSPF基本功能

# 配置SwitchA

[SwitchA] ospf 1 router-id 10.10.10.1

[SwitchA-ospf-1] area 0

[SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] quit

[SwitchA-ospf-1] area 1

[SwitchA-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.1] quit

[SwitchA-ospf-1] quit

 

# 配置SwitchB

[SwitchB] ospf 1 router-id 10.10.10.2

[SwitchB-ospf-1] area 1

[SwitchB-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255

[SwitchB-ospf-1-area-0.0.0.1] quit

[SwitchB-ospf-1] area 2

[SwitchB-ospf-1-area-0.0.0.2] network 172.16.0.0 0.0.255.255

[SwitchB-ospf-1-area-0.0.0.2] quit

[SwitchB-ospf-1] quit

 

# 配置SwitchC

[SwitchC] ospf 1 router-id 10.10.10.3

[SwitchC-ospf-1] area 0

[SwitchC-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[SwitchC-ospf-1-area-0.0.0.0] quit

[SwitchC-ospf-1] quit

 

# 配置SwitchD

[SwitchD] ospf 1 router-id 10.10.10.4

[SwitchD-ospf-1] area 2

[SwitchD-ospf-1-area-0.0.0.2] network 172.16.0.0 0.0.255.255

[SwitchD-ospf-1-area-0.0.0.2] quit

[SwitchD-ospf-1] quit

 

# 查看SwitchAOSPF路由表。

[SwitchA] display ospf routing

 

          OSPF Process 1 with Router ID 10.10.10.1

                   Routing Tables

 

 Routing for Network

 Destination        Cost  Type       NextHop         AdvRouter       Area

 10.1.1.0/24        1     Transit    10.1.1.1        10.10.10.1      0.0.0.0

 192.168.1.0/24     1     Transit    192.168.1.1     10.10.10.1      0.0.0.1

 

 Total Nets: 2

 Intra Area: 2  Inter Area: 0  ASE: 0  NSSA: 0

    由以上回显信息可以看出,SwitchA中并没有Area2中的路由信息。这是因为OSPF协议要求所有的非骨干区域必须与骨干区域保持连通,而Area2没有与Area0直接相连,所以SwitchA的路由表中没有Area2中的路由。

 

3.4、配置虚连接

# 配置SwitchA

[SwitchA] ospf 1

[SwitchA-ospf-1] area 1

[SwitchA-ospf-1-area-0.0.0.1] vlink-peer 10.10.10.2

[SwitchA-ospf-1-area-0.0.0.1] quit

[SwitchA-ospf-1] quit

 

# 配置SwitchB

[SwitchB] ospf 1

[SwitchB-ospf-1] area 1

[SwitchB-ospf-1-area-0.0.0.1] vlink-peer 10.10.10.1

[SwitchB-ospf-1-area-0.0.0.1] quit

[SwitchB-ospf-1] quit

 

4、验证配置结果

# 查看SwitchAOSPF路由表。

[SwitchA] display ospf routing

 

          OSPF Process 1 with Router ID 10.10.10.1

                   Routing Tables

 

 Routing for Network

 Destination        Cost  Type       NextHop         AdvRouter       Area

 10.1.1.0/24        1     Transit    10.1.1.1        10.10.10.1      0.0.0.0

 192.168.1.0/24     1     Transit    192.168.1.1     10.10.10.1      0.0.0.1

 172.16.0.0/16      2     Inter-area 192.168.1.2     10.10.10.2      0.0.0.0

 Total Nets: 3

 Intra Area: 2  Inter Area: 1  ASE: 0  NSSA: 0

    由以上回显信息可以看出,在SwitchASwitchB之间配置虚连接之后,SwitchAOSPF路由表中出现了Area2中的路由信息。

 

5、配置文件

5.1SwitchA的配置文件

#

sysname SwitchA

#

vlan batch 10 20

#

interface Vlanif10

 ip address 10.1.1.1 255.255.255.0

#

interface Vlanif20

 ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 20

#

ospf 1 router-id 10.10.10.1

 area 0.0.0.0

  network 10.1.1.0 0.0.0.255

 area 0.0.0.1

  network 192.168.1.0 0.0.0.255

  vlink-peer 10.10.10.2

#

return

 

5.2SwitchB的配置文件

#

sysname SwitchB

#

vlan batch 20 30

#

interface Vlanif20

 ip address 192.168.1.2 255.255.255.0

#

interface Vlanif30

 ip address 172.16.1.1 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 20

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 30

#

ospf 1 router-id 10.10.10.2

 area 0.0.0.1

  network 192.168.1.0 0.0.0.255

  vlink-peer 10.10.10.1

 area 0.0.0.2

  network 172.16.0.0 0.0.255.255

#

return

 

5.3SwitchC的配置文件

#

sysname SwitchC

#

vlan batch 10

#

interface Vlanif10

 ip address 10.1.1.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

ospf 1 router-id 10.10.10.3

 area 0.0.0.0

  network 10.1.1.0 0.0.0.255

#

return

 

5.4SwitchD的配置文件

#

sysname SwitchD

#

vlan batch 30

#

interface Vlanif30

 ip address 172.16.1.2 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 30

#

ospf 1 router-id 10.10.10.4

 area 0.0.0.2

  network 172.16.0.0 0.0.255.255

#

return

 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:647682417 互相学习。     
本文地址:http://www.023wg.com/lypz/190.html
版权声明:若无注明,本文皆为“杭州清默网络”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:杭州清默网络    杭州清默网络