华为RIP路由基本功能配置示例
首页 > HuaWei > 路由配置   作者:浙江思唯网络  2016年2月16日 17:16 星期二  字号:   评论:2 条
时间:2016-2-16 17:16   评论:2 条 

华为RIP路由基本功能配置示例

1、组网需求

       RIP路由基本功能组网示例图.png

1  RIP路由基本功能组网示例图

如上图1所示,在小型网络中有4台交换机,要求在SwitchASwitchBSwitchCSwitchD上采用RIP实现网络互连。


2、配置思路

2.1、配置各接口所属VLANIP地址,使网络可达。

2.2、在各交换机上使能RIP,基本实现网络互连。

2.3、在各交换机上配置RIP-2版本,提升RIP路由扩展性能。

 

3、操作步骤

3.1、配置各接口所属的VLANSwitchBSwitchCSwitchD的配置与SwitchA类似。

<HUAWEI> system-view

[HUAWEI] sysname SwitchA

[SwitchA] vlan 10

[SwitchA-vlan10] quit

[SwitchA] interface gigabitethernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] port link-type trunk

[SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10

[SwitchA-GigabitEthernet1/0/1] quit

 

3.2、配置各VLANIF接口的IP地址。SwitchBSwitchCSwitchD的配置与SwitchA类似。

[SwitchA] interface vlanif 10

[SwitchA-Vlanif10] ip address 192.168.1.1 24

[SwitchA-Vlanif10] quit

 

3.3、配置RIP基本功能

# 配置SwitchA

[SwitchA] rip

[SwitchA-rip-1] network 192.168.1.0

[SwitchA-rip-1] quit

 

# 配置SwitchB

[SwitchB] rip

[SwitchB-rip-1] network 192.168.1.0

[SwitchB-rip-1] network 172.16.0.0

[SwitchB-rip-1] network 10.0.0.0

[SwitchB-rip-1] quit

 

# 配置SwitchC

[SwitchC] rip

[SwitchC-rip-1] network 172.16.0.0

[SwitchC-rip-1] quit

 

# 配置SwitchD

[SwitchD] rip

[SwitchD-rip-1] network 10.0.0.0

[SwitchD-rip-1] quit

 

# 查看SwitchARIP路由表。

[SwitchA] display rip 1 route

 Route Flags : R - RIP

              A - Aging, G - Garbage-collect

----------------------------------------------------------------------------

 Peer 192.168.1.2  on Vlanif10

      Destination/Mask        Nexthop     Cost   Tag     Flags   Sec

       172.16.0.0/16       192.168.1.2      1    0        RA      14

         10.0.0.0/8        192.168.1.2      1    0        RA      14

从路由表中可以看出,RIP-1发布的路由使用的是自然掩码。

 

3.4、配置RIP的版本号

# SwitchA上配置RIP-2

[SwitchA] rip

[SwitchA-rip-1] version 2

[SwitchA-rip-1] quit

 

# SwitchB上配置RIP-2

[SwitchB] rip

[SwitchB-rip-1] version 2

[SwitchB-rip-1] quit

 

# SwitchC上配置RIP-2

[SwitchC] rip

[SwitchC-rip-1] version 2

[SwitchC-rip-1] quit

 

# SwitchD上配置RIP-2

[SwitchD] rip

[SwitchD-rip-1] version 2

[SwitchD-rip-1] quit

 

4、验证配置结果

# 查看SwitchARIP路由表。

[SwitchA] display rip 1 route

Route Flags : R - RIP

             A - Aging, G - Garbage-collect

----------------------------------------------------------------------------

 Peer 192.168.1.2  on Vlanif10

      Destination/Mask        Nexthop       Cost   Tag     Flags   Sec

       172.16.1.0/24         192.168.1.2      1    0        RA      32

         10.1.1.0/24         192.168.1.2      1    0        RA      32

从路由表中可以看出,RIP-2发布的路由中带有更为精确的子网掩码信息。

 

5、配置文件

5.1SwitchA的配置文件

#

sysname SwitchA

#

vlan batch 10

#

interface Vlanif10

 ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

rip 1

 version 2

 network 192.168.1.0

#

Return

 

5.2SwitchB的配置文件

#

sysname SwitchB

#

vlan batch 10 20 30

#

interface Vlanif10

 ip address 192.168.1.2 255.255.255.0

#

interface Vlanif20

 ip address 172.16.1.1 255.255.255.0

#

interface Vlanif30

 ip address 10.1.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 20

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk allow-pass vlan 30

#

rip 1

 version 2

 network 192.168.1.0

 network 172.16.0.0

 network 10.0.0.0

#

Return

 

5.3SwitchC的配置文件

#

sysname SwitchC

#

vlan batch 20

#

interface Vlanif20

 ip address 172.16.1.2 255.255.255.0

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 20

#

rip 1

 version 2

 network 172.16.0.0

#

Return

 

5.4SwitchD的配置文件

#

sysname SwitchD

#

vlan batch 30

#

interface Vlanif30

 ip address 10.1.1.2 255.255.255.0

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk allow-pass vlan 30

#

rip 1

 version 2

 network 10.0.0.0

#

return



 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:647682417 互相学习。     
本文地址:http://www.023wg.com/lypz/175.html
版权声明:若无注明,本文皆为“思唯网络教育博客”原创,转载请保留文章出处。
ASDF2016-03-12 02:16
VLAN不配置物理接口能ping通自己吗?
圈圈哥2016-03-12 16:52
@ASDF:没有理解到你意思 请加群 详聊
返回顶部    首页   
版权所有:思唯网络教育博客    浙江思唯网络