服务器集群(多端口)ARP配置示例
首页 > HuaWei > ARP   作者:圈哥  2016年2月13日 17:04 星期六  字号:   评论:0 条
时间:2016-2-13 17:04   评论:0 条 

 服务器集群(多端口)ARP配置示例

1、组网需求

     服务器集群(多端口)ARP组网示例图.png

  图1 服务器集群(多端口)ARP组网示例图

如上图1所示,Switch连接NLB服务器群,该NLB服务器群工作在单播模式,通过属于VLAN10的三个接口GE1/0/1GE1/0/2GE1/0/3分别连接三台服务器。

服务器群的群集IP地址为192.168.1.1/24,群集MAC地址为02bf-fc01-0000。要求交换机能够将目的地址为192.168.1.1的报文发送到群集内的所有服务器上。

 

2、配置思路

配置多端口单播MAC表项并配置一条静态ARP表项,实现IP数据报文能同时发送到三台服务器上。

 

3、操作步骤

3.1、创建VLAN,并将接口加入到VLAN

# 创建VLAN10

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] vlan 10

[Switch-vlan10] quit

 

# 把接口GE1/0/1GE1/0/2GE1/0/3分别加入VLAN10

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type access

[Switch-GigabitEthernet1/0/1] port default vlan 10

[Switch-GigabitEthernet1/0/1] quit

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port default vlan 10

[Switch-GigabitEthernet1/0/2] quit

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port default vlan 10

[Switch-GigabitEthernet1/0/3] quit

 

3.2、创建接口VLANIF10,并配置IP地址

[Switch] interface vlanif 10

[Switch-Vlanif10] ip address 192.168.1.2 24

[Switch-Vlanif10] quit

 

3.3、配置多端口单播MAC表项并配置一条静态ARP表项。

配置多端口单播MAC表项,MAC地址为02bf-fc01-0000VLAN10,对应的出接口为GE1/0/1GE1/0/2GE1/0/3

[Switch] mac-address multiport 02bf-fc01-0000 interface gigabitethernet 1/0/1 to gigabitethernet 1/0/3 vlan 10

 

配置一条静态ARP表项,IP地址为192.168.1.1,对应的MAC地址为02bf-fc01-0000

[Switch] arp static 192.168.1.1 02bf-fc01-0000

[Switch] quit

 

4、检查配置结果

# Switch上使用display mac-address multiport vlan 10命令,查看已配置的多端口MAC表项信息。

<Switch> display mac-address multiport vlan 10

--------------------------------------------------------------------------------

MAC Address       VLANID    Out-Interface               Status                                                                     

02bf-fc01-0000    10        GigabitEthernet1/0/1        Active                               

                            GigabitEthernet1/0/2        Active                                

                            GigabitEthernet1/0/3        Active                               

                                            3 port(s)                          

--------------------------------------------------------------------------------

 Total Group(s) : 1

 

# Switch上使用display arp命令,查看ARP表项信息。

<Switch> display arp

IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE 

                                          VLAN/CEVLAN                          

------------------------------------------------------------------------------

192.168.1.1     02bf-fc01-0000            S--         Multi-port:3           

------------------------------------------------------------------------------ 

Total:1        Dynamic:0      Static:1     Interface:0

 

5、配置文件

以下仅给出Switch的配置文件。

#

sysname Switch

#

vlan batch 10

#

interface Vlanif10

 ip address 192.168.1.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 10

 mac-address multiport 02bf-fc01-0000 vlan 10

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 10

 mac-address multiport 02bf-fc01-0000 vlan 10

#

interface GigabitEthernet1/0/3

 port link-type access

 port default vlan 10

 mac-address multiport 02bf-fc01-0000 vlan 10

#

arp static 192.168.1.1 02bf-fc01-0000

#

return

 

 您阅读这篇文章共花了: 
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428互相学习。     
本文地址:http://www.023wg.com/arp/170.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:重庆网管    圈哥