华为交换机VLAN之间Proxy ARP示例
首页 > HuaWei > ARP   作者:圈哥  2016年2月11日 16:57 星期四  热度:2113°  字号:   评论:0 条
时间:2016-2-11 16:57   热度:2113°  评论:0 条 
 华为交换机VLAN之间Proxy ARP示例

1、组网需求

     VLAN间Proxy ARP组网示例图.png

            图1 VLANProxy ARP组网示例图

如上图1所示,VLAN2VLAN3组成Super-VLAN4。要求:

作为Sub-VLANVLAN2VLAN3内的主机之间不能互相Ping通。

配置VLANProxy ARP(代理arp)后,VLAN2VLAN3内的主机之间可以互相Ping通。

 

2、配置思路

2.1、配置Super-VLANSub-VLAN

2.2、将接口加入到从Sub-VLAN中。

2.3、创建Super-VLANVLANIF接口并配置其IP地址。

2.4、启动VLANProxy ARP

 

3、操作步骤

3.1、配置Super-VLANSub-VLAN

# 配置Sub-VLAN2

<HUAWEI> system-view

[HUAWEI] vlan 2

[HUAWEI-vlan2] quit

 

# GE1/0/1GE1/0/2加入到Sub-VLAN2中。

[HUAWEI] interface gigabitethernet 1/0/1

[HUAWEI-GigabitEthernet1/0/1] port link-type access

[HUAWEI-GigabitEthernet1/0/1] port default vlan 2

[HUAWEI-GigabitEthernet1/0/1] quit

[HUAWEI] interface gigabitethernet 1/0/2

[HUAWEI-GigabitEthernet1/0/2] port link-type access

[HUAWEI-GigabitEthernet1/0/2] port default vlan 2

[HUAWEI-GigabitEthernet1/0/2] quit

 

# 配置Sub-VLAN3

[HUAWEI] vlan 3

[HUAWEI-vlan3] quit

 

# GE1/0/3GE1/0/4加入到Sub-VLAN3中。

[HUAWEI] interface gigabitethernet 1/0/3

[HUAWEI-GigabitEthernet1/0/3] port link-type access

[HUAWEI-GigabitEthernet1/0/3] port default vlan 3

[HUAWEI-GigabitEthernet1/0/3] quit

[HUAWEI] interface gigabitethernet 1/0/4

[HUAWEI-GigabitEthernet1/0/4] port link-type access

[HUAWEI-GigabitEthernet1/0/4] port default vlan 3

[HUAWEI-GigabitEthernet1/0/4] quit

 

# 配置Super-VLAN4,并将Sub-VLAN2Sub-VLAN3增加到Super-VLAN中。

[HUAWEI] vlan 4

[HUAWEI-vlan4] aggregate-vlan

[HUAWEI-vlan4] access-vlan 2

[HUAWEI-vlan4] access-vlan 3

[HUAWEI-vlan4] quit

 

3.2、创建和配置接口VLANIF4

# 创建接口VLANIF4

[HUAWEI] interface vlanif 4

 

# 配置接口VLANIF4IP地址。

[HUAWEI-Vlanif4] ip address 10.10.10.1 24

 

# 在接口VLANIF4启动VLANProxy ARP

[HUAWEI-Vlanif4] arp-proxy inter-sub-vlan-proxy enable

[HUAWEI-Vlanif4] quit

 

4、检查配置结果

4.1、执行命令display current-configuration,查看Super-VLANSub-VLAN以及VLANIF接口的相关配置。查询结果请见下面给出的配置文件。

4.2VLAN2VLAN3内的主机之间可以互相Ping通。

 

5、配置文件

以下仅给出Switch的配置文件。

#

sysname HUAWEI

#

vlan batch 2 to 4

#

vlan 4

 aggregate-vlan

 access-vlan 2 to 3

#

interface Vlanif4

 ip address 10.10.10.1 255.255.255.0

 arp-proxy inter-sub-vlan-proxy enable

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 2

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 2

#

interface GigabitEthernet1/0/3

 port link-type access

 port default vlan 3

#

interface GigabitEthernet1/0/4

 port link-type access

 port default vlan 3

#

return

 

 

 您阅读这篇文章共花了: 
捐赠支持:如果觉得这篇文章对您有帮助,请“扫一扫”鼓励作者!
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428 互相学习。     
本文地址:http://www.023wg.com/arp/166.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页    捐赠支持   
版权所有:重庆网管    圈哥