华为交换机VLAN内Proxy ARP配置示例
首页 > HuaWei > ARP   作者:圈哥  2016年2月4日 17:00 星期四  热度:1223°  字号:   评论:0 条
时间:2016-2-4 17:00   热度:1223°  评论:0 条 

华为交换机VLANProxy ARP配置示例

1、组网需求

       VLAN内Proxy ARP组网示例图.png

                          图1 VLANProxy ARP组网示例图

如上图1所示,Switch的接口GE1/0/2GE1/0/1属于同一个sub-VLAN2。该sub-VLAN属于super-VLAN3。要求:

属于同一VLAN2的两台主机hostAhostB之间二层隔离。

hostAhostB之间通过VLANProxy ARP实现三层互通。

Super-VLANVLANIF接口的IP地址为10.10.10.1,子网掩码为255.255.255.0

 

2、配置思路

2.1、创建和配置Super-VLANSub-VLAN

2.2、将接口加入到从Sub-VLAN中。

2.3、创建Super-VLANVLANIF接口并配置其IP地址。

2.4、在Super-VLANVLANIF接口使能VLANProxy ARParp代理)功能。

 

3、操作步骤

3.1、配置Super-VLANSub-VLAN

# 配置Sub-VLAN2

<HUAWEI> system-view

[HUAWEI] vlan 2

[HUAWEI-vlan2] quit

 

# 使能GE1/0/1GE1/0/2端口隔离功能。

[HUAWEI] port-isolate mode l2

[HUAWEI] interface gigabitethernet 1/0/1

[HUAWEI-GigabitEthernet1/0/1] port-isolate enable

[HUAWEI-GigabitEthernet1/0/1] quit

[HUAWEI] interface gigabitethernet 1/0/2

[HUAWEI-GigabitEthernet1/0/2] port-isolate enable

[HUAWEI-GigabitEthernet1/0/2] quit

 

# GE1/0/1GE1/0/2加入到Sub-VLAN2中。

[HUAWEI] interface gigabitethernet 1/0/1

[HUAWEI-GigabitEthernet1/0/1] port link-type access

[HUAWEI-GigabitEthernet1/0/1] port default vlan 2

[HUAWEI-GigabitEthernet1/0/1] quit

[HUAWEI] interface gigabitethernet 1/0/2

[HUAWEI-GigabitEthernet1/0/2] port link-type access

[HUAWEI-GigabitEthernet1/0/2] port default vlan 2

[HUAWEI-GigabitEthernet1/0/2] quit

 

# 配置Super-VLAN3,并将Sub-VLAN2增加到Super-VLAN中。

[HUAWEI] vlan 3

[HUAWEI-vlan3] aggregate-vlan

[HUAWEI-vlan3] access-vlan 2

[HUAWEI-vlan3] quit

 

3.2、创建和配置接口VLANIF3

# 创建接口VLANIF3

[HUAWEI] interface vlanif 3

 

# 配置接口VLANIF3IP地址。

[HUAWEI-Vlanif3] ip address 10.10.10.1 24

 

3.3、在接口VLANIF3启动VLANProxy ARP

[HUAWEI-Vlanif3] arp-proxy inner-sub-vlan-proxy enable

[HUAWEI-Vlanif3] quit

 

4、检查配置结果

4.1、执行命令display current-configuration,查看Super-VLANSub-VLAN以及VLANIF接口的相关配置。查询结果请见下面给出的配置文件。

4.2 hostAhostB互相可以Ping通。

 

5、配置文件

以下仅给出Switch的配置文件。

#

sysname HUAWEI

#

vlan batch 2 to 3

#

vlan 3

 aggregate-vlan

 access-vlan 2

#

interface Vlanif3

 ip address 10.10.10.1 255.255.255.0

 arp-proxy inner-sub-vlan-proxy enable

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 2

 port-isolate enable group 1

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 2

 port-isolate enable group 1

#

return

 您阅读这篇文章共花了: 
捐赠支持:如果觉得这篇文章对您有帮助,请“扫一扫”鼓励作者!
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428 互相学习。     
本文地址:http://www.023wg.com/arp/164.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页    捐赠支持   
版权所有:重庆网管    圈哥