路由式ARP Proxy​(arp代理)配置示例
首页 > HuaWei > ARP   作者:圈哥  2016年2月3日 16:53 星期三  热度:1804°  字号:   评论:0 条
时间:2016-2-3 16:53   热度:1804°  评论:0 条 

路由式ARP Proxyarp代理)配置示例

1、组网需求

        路由式Proxy ARP组网示例图.png

                     图1 路由式ARP Proxy组网示例图

如上图1所示,Switch的两个以太网接口GE1/0/1GE1/0/2分别连接一个局域网,两个局域网的网段均为172.16.0.0/16。两台计算机HostAHostB没有配置默认网关,要求在Switch上配置路由式ARP Proxy (arp代理),使分处在两个局域网的主机能互通。

 

2、配置思路

2.1、配置接口的IP地址

2.4、在接口使能路由式ARP Proxy功能

 

3、操作步骤

3.1、创建VLAN2,并将GE1/0/1加入到VLAN中。

<HUAWEI> system-view

[HUAWEI] vlan 2

[HUAWEI-vlan2] quit

[HUAWEI] interface gigabitethernet 1/0/1

[HUAWEI-GigabitEthernet1/0/1] port link-type access

[HUAWEI-GigabitEthernet1/0/1] port default vlan 2

[HUAWEI-GigabitEthernet1/0/1] quit

 

3.2、创建并配置接口VLANIF2

[HUAWEI] interface vlanif 2

[HUAWEI-Vlanif2] ip address 172.16.1.1 255.255.255.0

 

3.3、在VLANIF2上使能路由式Proxy ARP功能。

[HUAWEI-Vlanif2] arp-proxy enable

[HUAWEI-Vlanif2] quit

 

3.4、创建VLAN3,并将GE1/0/2加入到VLAN中。

[HUAWEI] vlan 3

[HUAWEI-vlan3] quit

[HUAWEI] interface gigabitethernet 1/0/2

[HUAWEI-GigabitEthernet1/0/2] port link-type access

[HUAWEI-GigabitEthernet1/0/2] port default vlan 3

[HUAWEI-GigabitEthernet1/0/2] quit

 

3.5、创建并配置接口VLANIF3

[HUAWEI] interface vlanif 3

[HUAWEI-Vlanif3] ip address 172.16.2.1 255.255.255.0

 

3.6、在VLANIF3上使能路由式Proxy ARP功能。

[HUAWEI-Vlanif3] arp-proxy enable

[HUAWEI-Vlanif3] quit

 

4、配置主机

# 配置主机HostAIP地址为172.16.1.2/16

# 配置主机HostBIP地址为172.16.2.2/16

 

5、验证配置结果

# 主机HostAping主机HostB,可以通。

 

6、配置文件

Switch的配置文件

#

sysname HUAWEI

#

vlan batch 2 to 3

#

interface Vlanif2

 ip address 172.16.1.1 255.255.255.0

 arp-proxy enable

#

interface Vlanif3

 ip address 172.16.2.1 255.255.255.0

 arp-proxy enable

#

interface GigabitEthernet1/0/1

 port link-type access

 port default vlan 2

#

interface GigabitEthernet1/0/2

 port link-type access

 port default vlan 3

#

return

 您阅读这篇文章共花了: 
捐赠支持:如果觉得这篇文章对您有帮助,请“扫一扫”鼓励作者!
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:481294053/474079428 互相学习。     
本文地址:http://www.023wg.com/arp/162.html
版权声明:若无注明,本文皆为“重庆网管”原创,转载请保留文章出处。

返回顶部    首页    捐赠支持   
版权所有:重庆网管    圈哥