【思唯网络学院】小白逆袭!思科基础命令大全,建议收藏~
首页 > >   作者:浙江思唯网络  2020年3月20日 18:15 星期五  字号:   评论:0 条
时间:2020-3-20 18:15   评论:0 条 

思科 基本端口设置命令

no ip routing 二层交换关闭路由功能

configure terminal (conf t) 进入全局模式

interface fastEthernet 1/0 (int f1/0) 进入端口1/0 简写int f1/0

speed 100 设置速率为100MB

duplex full 设置端口为双工 half 半双工

show interfaces fastEthernet 1/0 在用户模式下显示 端口信息

do show interface fastEtherne 1/0 在端口或者全局模式显示 端口信息

show ip interface brie 显示所有端口和vlan的IP地址


vlan创建命令

dir 查看设备存储空间

erase flash: 格式化存储空间

vlan database 进入vlan数据模式

在数据模式下

vlan 10 name caiwu 创建vlan10,名字为caiwu

abort 退出vlan数据模式

show vlan-switch brief 用户模式查看vlan 情况

do show vlan-switch brief 在全局模式下查看vlan情况

vlan 20 直接创建vlan 20

vlan 20 name renshi 先进入vlan20 在修改名字为renshi

switchport mode access (sw mo acc) 设置端口为接入模式

switchport access vlan 10 添加端口为vlan10

interface range fastEthernet 1/1 -2 进入连续的多个端口进行设置

switchport mode trunk 设置端口为trunk模式

switchport trunk encapsulation dot1q 给trunk端口封装协议


默认路由和静态路由

ip ip address 192.168.10.1 255.255.255.0 给端口配置IP地址

no shutdown 启动端口 在路由 或者三层交换上面

ip route 0.0.0.0 0.0.0.0 1.1.1.1(下一跳地址) 添加默认路由

ip route 192.168.10.0 255.255.255.0 1.1.1.1(下一跳地址) 添加静态路由


三层交换

do show interfaces fastEthernet 1/0 switchport 查看端口协议

vlan 10 创建vlan

interface vlan num 进入 vlan

ip address 192.168.100.1 255.255.255.0 创建vlan的网关地址

interface range fastEthernet 1/1 -4 进入连续的多个端口

channel-group 1 mode on 绑定两个trunk端口增加链路,增加带宽

即使一条链路损坏也不影响


RIP路由协议

router rip 启用rip协议进程

network 192.168.10.0 声明直联网段

version 2 启用rip2版本

no auto-summary 关闭汇聚功能

do show ip route 在全局模式查看路由表


OSPF路由协议

interface loopback 1 进入回环网口

no shutdown 激活端口

router ospf 1 启动ospf进程1

router-id 例(1.1.1.1) 设置routerID

network 192.168.10.0 0.0.0.255 area 0 宣告网段在area 0区域,注意反掩码!!!

show running-config 用户模式查看所有进程

no router ospf 进程ID 清除OSPF进程

redistribute connected subnets 注入直联网段

redistribute static subnets 注入静态路由网段

default-infomation originate 注入外部默认路由

redistribute ospf 1 metric 5 在rip协议中注入ospf协议

redistribute rip subnets 在ospf协议注入rip协议


标准ACL访问列表 针对源IP地址

access-list 1-99 permit A.B.C.D 0.0.0.0 (反掩码)

permit host A.B.C.D 允许该IP地址访问流量

写允许规则 默认拒绝所有

access-list 1-99 deny A.B.C.D 0.0.0.0(反掩码)

deny host A.B.C.D 拒绝该IP地址访问流量

必须要写 permit any 允许其他IP地址访问流量

do show access-list 全局模式,查看ACL已写规则列表

ip access-group 1 in/out 进入端口,作用于端口

no ip access-group 1 in/out 取消应用于端口

no access-list 1 删除整个ACL列表


扩展ACL访问列表

(100-19) 源IP地址 目标IP地址 等于 服务名或端口

access-list 100 permit tcp host 192.168.1.2 host 192.168.100.100 eq www(或端口)

允许192.168.1.2访问http服务

acess-list 100 deny ip host 192.168.1.2 host 192.168.100.100

拒绝192.168.1.2访问其他服务

access-list 100 permit ip host 192.168.1.2 192.168.2.0 0.0.0.255

允许192.168.1.2访问目标网段192.168.2.0


命名型ACL访问控制列表

  • access-list (standard/extended) kgc

写法跟标准和扩展一样

删除条目 no 条目编号

ip access-group kgc out/in 进入端口然后应用端口


静态NAT

ip nat inside source static 192.168.100.20 12.0.0.20 转换私网地址为公网地址

ip nat inside/outside 应用于端口

debug ip nat 启动debug模式监听NAT状态

ip nat inside source static tcp 192.168.100.100 80 12.0.0.100 8080 extendable


动态NAT

access-list 1 permit 192.168.100.0 0.0.0.255 允许网段地址

ip nat pool test 12.0.0.10 12.0.0.100 netmask 255.255.255.0 转换成的地址池名test

ip nat inside source list 1 pool test 把允许网段地址转换为地址池

ip nat inside/outside 应用于端口

debug ip nat 在用户模式启动debug模式


PAT端口多路复用

access-list 1 permit 192.168.100.0 0.0.0.255 添加ACL允许网段

ip nat inside source list 1 interface fastEthernet 0/1 overload 设置网段伪装成0/1端口IP

ip nat inside/outside 应用于端口

 您阅读这篇文章共花了: 
 本文无需标签!
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:859273036 互相学习。     
本文地址:http://www.023wg.com/846.html
版权声明:若无注明,本文皆为“思唯网络学院博客”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:思唯网络学院博客    浙江思唯网络