【思唯网络学院】HCNP的一些笔记分享
首页 > >   作者:浙江思唯网络  2019年12月23日 15:35 星期一  字号:   评论:0 条
时间:2019-12-23 15:35   评论:0 条 
HCNP的一些笔记分享,需要的可收藏。



OSPF(开放式最短路径优先协议,协议号89)

特点:

支持无类域间路由(CIDR)

无路由自环

收敛速度快(10s发送一次,老化时间40s)

使用IP组播收发协议数据

支持多条等值路由

支持协议报文的认证

每个非骨干区域都需要与骨干区域相连,传递LSA,每隔30分钟泛洪LSA

相同区域上的路由器具有相同的LSDB,不同区域的LSDB则不同


划分区域的优点:减少LSDB的规模,减少网络流量。


路由器的分类:IR  BR  ASBR(自治系统边间路由器)  ABR(区域边界路由器)



基本配置

[RTA]OSPF router id 1.1.1.1  (自治系统好默认为1)

[RTA-ospf-1]area 1

[RTA-ospf-1-area-0.0.0.1]network 1.1.1.1 0.0.0.0

[RTA-ospf-1-area-0.0.0.1]network 10.1.1.0 0.0.0.255   (反掩码)

[RTA-ospf-1-area-0.0.0.1]return

状态机:down  init  2way  exstart  exchange  loading  full

外部引入的OSPF 路由优先级为150


LSA的五种类型 

          通告者    传播范围                 内容

类型1:  本设备    本区域内             直连链路的拓扑,路由信息

类型2:   DR       本区域内                MA网络号+掩码 所有路由器ID

类型3:   ABR      整个OSPF 区域      域间路由

类型4:   ABR      整个OSPF 区域      所在区域要到达目标网络的路径

类型5:   ASBR     整个OSPF 区域     域外路由


             LINK ID                     ADV ID

LSA 1    通告者ID                   通告者ID

LSA 2    DR接口ip地址           通告者ID

LSA 3    域间路由的网络号    

LSA 4    ASBR的router ID 

LSA 5    域外路由的网络号

LSA 7    特殊区域的域外路由网络号 



DR(指定路由器) BDR(备份指定路由器)Drother (其他路由器)作用:减少邻接关系的建立,从而减少LSA信息交换的次数,可以节省带宽,减少路由器的负担。


邻居:可以发送hello包,维持邻居关系


邻接:可以交互LSA信息

靠hello包来选举DR 和BDR,优先级(缺省为1)+router id,优先级为0 时,没有资格选举DR 和BDR


NBMA 非广播多路网络


路由汇总

DR或者BDR优先权可修改。


OSPF 报文:hello,DD ,LSR ,LSU, LSACK


224.0.0.5 组播地址


224.0.0.6(DR BDR进行侦听的地址)


OSPF 多进程:ospf进程号,本地有效,同一设备,起不同的ospf进程他们相互之间不用交互路由。


OSPF 特殊区域:目的在于减少LSA的泛洪


OSPF 区域分类:              

Stub区域(只有LSA1,LSA2,LSA3,且只有一个ABR,不可以配置在骨干区域当中,区域内都必须配置为Stub,不可以存在虚链接)


配置:

[RTA]router id 1.1.1.1

[RTA]ospf 

[RTA-ospf-1]area 1

[RTA-ospf-1-area-0.0.0.1]network 1.1.1.1 0.0.0.0

[RTA-ospf-1-area-0.0.0.1]network 10.1.1.0 0.0.0.3

[RTA-ospf-1-area-0.0.0.1]stub      //将area1 配置为stub区域


Totally stub:内容大致和stub一致,过滤掉LSA3,LSA4,LSA5


配置:

[RTB]ospf

[RTB-ospf-1]area 1

[RTB-ospf-1-area-0.0.0.1]stub no-summary     //配置为完全末节区域


NSSA区域:以stub区域为基础,可以引入外部路由,但是以LSA7来进行显示,包含LSA1,LSA2,LSA3 ,LSA7  ABR默认在区域下发LSA7的默认路由来指向自己。(当NSSA有多台ABR的时候,只有一台ABR会将LSA7转化为LSA5,发送到其他区域,为了避免环路的出现,router-id越大越优来选举设备来发送)


Totally nssa区域:过滤LSA3(即域间路由),LSA4,LSA5,ABR将会向区域内下发默认路由,LSA3,LSA7, 域内路由》域间路由》域外路由

认证:区域认证,接口认证(接口认证优于区域认证)

抑制接口:rip(只接收rip,不发送报文,)ospf(既不接收也不发送报文)


查看ospf数据库命令:display ospf  lsdb  router类型1 (network类型


2、summary类型3 ase类型5)

查看DR和BDR 选举情况:display ospf interface

修改ospf的优先权:ospf dr-priority 2  (需在指定接口上配置)

重启ospf进程:reset ospf 1 process

配置ospf的被动端口:【R2-OSPF-1】silent-interface Ethernet 1/0/0

OSPF md5认证:ospf authentication-mode md5 24 cipher *** (24为标识符)

简单区域认证:【】authentication-mode simple plain  ***

网络类型:NBMA  P2P  P2MP  BMA(NBMA的网络多用于帧中继网络中,且邻居之间的关系需要手动配置)

配置回环口的网络类型:[R2-LoopBack0]ospf network-type broadcast



路由策略

路由引入(路由重分布)

Rip引入到ospf区域中,优先级为150,外部路由引入ISIS 中时,优先级依旧为15

例:ip ip-prefix test index 10 permit 10.0.0.0 16 greater-equal 24 less-equal 28(test为名称,10为序列号,16为精确匹配到该地址的前两位)


路由策略配置:

route-policy RP deny node 10   (RP为路由策略的名称,10 为序列号)

 if-match ip-prefix Pref1     (表示匹配到名称为pref1的前缀列表)


router policy :

filter policy :主要用于过滤路由信息

import:

export:

链路状态路由协议

Import:入方向

Export:控制外部路由



BGP(边界网关路由协议)

属于EGP(外部网关协议),应用在两个AS系统之间,距离矢量路由协议,传输协议TCP ,端口号179,进行的是增量更新,周期性发送keepalive报文测试TCP连通性

公有自治系统号范围:1--64511

私有自治系统号范围:64512—65535



BGP报文有五种类型:

1 Open:负责和对等体建立邻居关系。(老化时间180s)

2 KeepAlive:该消息在对等体之间周期性地发送,用以维护连接。

3 Update:该消息被用来在BGP对等体之间传递路由信息。

4 Notification:当BGP Speaker检测到错误的时候,就发送该消息给对等体。

5 Route-refresh:用来通知对等体自己支持路由刷新能力。



BGP的两种邻居关系:IBGP   EBGP


EBGP:BGP设备从EBGP邻居接收到路由,如果里面的AS-PATH有本地的AS号,就会选择丢弃,(用物理接口来建立邻居,ttl值为1)


IBGP:同一个AS号,BGP设备从IBGP邻居学到的路由,不会传递给其他IBGP 的邻居(用环回接口,考虑到冗余链路,出于稳定性,ttl值为255)


路由聚合

自动聚合:主要针对于外部路由引入的聚合



手动聚合:主要针对的是BGP network出来的路由(优先级高于自动聚合)



aggregate 160.0.0.0 255.0.0.0 detail-suppressed as-set(as-set表示携带路由的属性)

修改Attribute policy




本地优先级:只在同一个AS内传递,BGP路由到达同一目的网段有多条路径的时候,选选择优先级高的路径走。

MED值,默认情况下为0 ,越小越优




IP 组播

D类地址用于组播

广播:一对所有   单播:一对一   组播:一对多

组播源,发送数据

组播路由器:生成组播路由表(组播路由器之间运行PIM协议)


组播组成员:接收数据(使用IGMP协议与组播路由器进行交流)

一个组播组就是一个IP地址,不表示具体的主机,而是表示一系列系统的集合,


组播地址范围:224---239

分类:ASM(组播组成员无法区分组播源)

         SSM(可以区分组播源)


组播地址分类:永久组播地址

                       临时组播地址


IP组播帧都使用以0x0100.5Exx.xxxx的24位前缀开始的MAC层地址。

组播IP 与mac地址的影射,以前面24位作为前缀,复制组播IP 地址的23位形成


MSDP:组播源发现协议

MBGP:

组播分发树:源路径树  STP    共享树  RTP

反向路径转发RPF(路由器收到组播数据报文后,只有确认这个数据报文是从自身连接到组播源的接口上收到的,才进行转发,否则丢弃),因此使用检查单播路由表的方式来检查,


IGMP因特网组管理协议(在IP主机和与其直接相邻的组播路由器之间)


版本:IGMPv1,IGMPv2,IGMPv3

224.0.0.1代表所有节点

224.0.0.2代表所有组播路由

组播路由器每隔60s向主机发送查询。


配置:

[RTA]multicast routing-enable      //开启组播功能  

[RTA]interface ethernet0/0

[RTA-Ethernet0/0]ip address 172.16.1.3 255.255.255.0 

[RTA-Ethernet0/0]igmp enable    //在接口上开启IGMP

[RTA-Ethernet0/0]igmp version 2    //设置IGMP的版本为2,默认情况下为版本2


查询命令

<RTD>display igmp interface     //查询哪些接口运行了IGMP

[RTB]display igmp group    //查询IGMP 的组

组播路由协议 PIM-DM(适用于规模较小的网络)   组播路由器之间运行组播路由协议,组播路由协议用于建立和维护组播路由,并正确、高效地转发组播数据包

RPF检查:用来防止环路

PIM-DM(扩散加修剪的过程来建立SPT树)

嫁接机制:用来缩短新加入组的反应时间。

Assert机制:用来防止源路由重复发送


配置:

[RTA]multicast routing-enable 

[RTA-Serial0/0]pim dm

PIM –SM(适用于规模较大的网络)

1. 单播互通

2. 开启组播功能

3. 将接口设置为PIM-SM模式

4. 选举RP(汇聚点),使用<RTC>display pim rp-info查询,使用static-rp  ****命令将RP确认下来,并在所有路由器上做同样的配置,让其他路由器知道RP

SM中发送IGMP 报文,join给汇聚点RP

在SM的网络中,以RP 做为分界点,源的一端运行SPT,与主机一端运行RPT,DR的选举是先根据优先级、再根据IP 地址来进行的。


VLAN

Vlan范围1-4096,当中的0和4095是被保留起来,实际可用到的是1-4094

Access接口(应用于主机和交换机之间,承载一个vlan)

收时:无标记时,打上PVID再查询MAC表

      有标记时,查询PVID,再查询MAC表

      有标记时,PVID不同,则丢弃

[Switch-Ethernet0/1]port link-type access

[Switch-Ethernet0/1]port default vlan 3

Trunk接口(应用于交换机之间,承载多个vlan)

收时:有标记时,查询vlan是否允许,再查询MAC表

      无标记时,打上PVID标记,是否在允许vlan中,再查询MAC表

发时:查询是否在vlan内,是否与PVID相同,则剥离标记转发出去

      查询是否在vlan内,与PVID号不同,则直接丢弃

[Switch]vlan 3

\\创建VLAN

[Switch-Ethernet0/3]port link-type trunk

\\配置端口类型

[Switch-Ethernet0/3]port trunk pvid vlan 3

\\配置Trunk-Link端口PVID

[Switch-Ethernet0/3]port trunk allow-pass vlan 5

\\配置Trunk-Link所允许通过的VLAN


Hybrid接口(应用于

[Quidway-Ethernet1/0/1]port link-type hybrid

[Quidway-Ethernet1/0/1]port hybrid pvid vlan 2

[Quidway-Ethernet1/0/1]port hybrid untagged vlan 2


MUX VLAN技术

分为主vlan和从vlan,从vlan可以分为互通型vlan和隔离vlan

  1. 主vlan可以和任何从vlan进行相互通信。

  2. 从vlan之间不可以互访。

  3. 互通vlan内可以互访

  4. 隔离型vlan内不可互访



ARP代理(思科默认开启,华为默认关闭)

ARP请求区分,如果请求目标地址与源地址一样,则直接请求目标地址,如果不同则请求网关

在接口上配置Arp-porcy enable

VLAN mapping

可以实现在用户VLAN ID(私有VLAN)和运营商VLAN ID(业务VLAN,也可以说是公有VLAN)之间相互转换的一个功能。

端口隔离技术

可将端口分为隔离端口和非隔离端口,隔离端口之间不可以互访,隔离端口和非隔离端口之间可以访问,并且在本地有效

[Quidway-GigabitEthernet2/0/2]port-isolate enable   //在端口GE2/0/2使能端口隔离功能



目前CCIE RS 笔试和LAB 稳定,持续过人中,了解之前的PASS情况和咨询考试情况

请加QQ:804990984 , 839898248

技术交流请加群:859273036,备注博客

扫描二维码也可以加群哦:
技术交流群.jpg




 您阅读这篇文章共花了: 
 本文无需标签!
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:859273036 互相学习。     
本文地址:http://www.023wg.com/731.html
版权声明:若无注明,本文皆为“思唯网络学院博客”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:思唯网络学院博客    浙江思唯网络