【思唯网络学院】主流厂商设备的PPPOE配置
首页 > >   作者:浙江思唯网络  2019年12月3日 15:42 星期二  字号:   评论:0 条
时间:2019-12-3 15:42   评论:0 条 
【思唯网络学院】主流厂商设备的PPPOE配置

1. 组网需求,
Host 运行 PPPoE Client,通过设备 Router 接入到 Internet。设备作为 PPPoE Server,配置本地认证,并通过地址池为用
户分配 IP 地址。设备 Router 通过 Ethernet1/1 接口连接以太网,Serial2/0 接口连接 Internet

<ccieh3c.qzone.qq.com-Router> system-view

[ccieh3c.qzone.qq.com-Router] local-user user1

[ccieh3c.qzone.qq.com-Router-luser-user1] password simple pass1

[ccieh3c.qzone.qq.com-Router-luser-user1] service-type ppp

[ccieh3c.qzone.qq.com-Router-luser-user1] quit

# 在设备 Router 上配置虚拟模板参数。

[ccieh3c.qzone.qq.com-Router] interface virtual-template 1

[ccieh3c.qzone.qq.com-Router-Virtual-Template1] ppp authentication-mode chap domain system

[ccieh3c.qzone.qq.com-Router-Virtual-Template1] ppp chap user user1

[ccieh3c.qzone.qq.com-Router-Virtual-Template1] remote address pool 1

[ccieh3c.qzone.qq.com-Router-Virtual-Template1] ip address 1.1.1.1 255.0.0.0

[ccieh3c.qzone.qq.com-Router-Virtual-Template1] quit

# 在设备 Router 上配置 PPPoE 参数。

[ccieh3c.qzone.qq.com-Router] interface ethernet 1/1

[ccieh3c.qzone.qq.com-Router-Ethernet1/1] pppoe-server bind virtual-template 1

[ccieh3c.qzone.qq.com-Router-Ethernet1/1] quit

# 配置域用户使用本地认证方案。

[ccieh3c.qzone.qq.com-Router] domain system

[ccieh3c.qzone.qq.com-Router-isp-system] authentication ppp local

# 增加一个本地 IP 地址池(9 个 IP 地址)

[ccieh3c.qzone.qq.com-Router-isp-system] ip pool 1 1.1.1.2 1.1.1.10

这样,以太网上各主机安装 PPPoE 客户端软件后,配置好用户名和密码(此处为 user1 和 pass1)就能使用 PPPoE 协议,
通过设备 Router 接入到 Internet。

若 通 过 authentication ppp 命 令 配 置 认 证 方 案 为 radius-scheme 或 hwtacacs-scheme , 那 么 还 需 要 配 置
RADIUS/HWTACAS 参数,使系统可以进行认证、授权、计费,具体配置步骤请参见“安全分册”中的“AAA 配置
PClient 典型配置举例

1. 组网需求
Router A 和 Router B 之间通过各自的 Ethernet1/1 接口相连,要求 Router A 用 PAP/CHAP 方式验证 Router B

方案一:PAP 认证
(1)
配置 Router A 作为 PPPoE Server

# 增加一个 PPPoE 用户

<ccieh3c.qzone.qq.com-RouterA> system-view

[ccieh3c.qzone.qq.com-RouterA] local-user user2

[ccieh3c.qzone.qq.com-RouterA-luser-user2] password simple hello

[ccieh3c.qzone.qq.com-RouterA-luser-user2] service-type ppp

[ccieh3c.qzone.qq.com-RouterA-luser-user2] quit

# 配置虚拟模板参数。

[ccieh3c.qzone.qq.com-RouterA] interface virtual-template 1

[ccieh3c.qzone.qq.com-RouterA-Virtual-Template1] ppp authentication-mode pap

[ccieh3c.qzone.qq.com-RouterA-Virtual-Template1] ip address 1.1.1.1 255.0.0.0

[ccieh3c.qzone.qq.com-RouterA-Virtual-Template1] remote address 1.1.1.2

[ccieh3c.qzone.qq.com-RouterA-Virtual-Template1] quit

# 配置 PPPoE Server。

[ccieh3c.qzone.qq.com-RouterA] interface ethernet 1/1

[ccieh3c.qzone.qq.com-RouterA-Ethernet1/1] pppoe-server bind virtual-template 1

(2)
配置 Router B 作为 PPPoE Client

<ccieh3c.qzone.qq.com-RouterB> system-view

[ccieh3c.qzone.qq.com-RouterB] dialer-rule 1 ip permit

[ccieh3c.qzone.qq.com-RouterB] interface dialer 1

[ccieh3c.qzone.qq.com-RouterB-Dialer1] dialer user user2

[ccieh3c.qzone.qq.com-RouterB-Dialer1] dialer-group 1

[ccieh3c.qzone.qq.com-RouterB-Dialer1] dialer bundle 1

[ccieh3c.qzone.qq.com-RouterB-Dialer1] ip address ppp-negotiate

[ccieh3c.qzone.qq.com-RouterB-Dialer1] ppp pap local-user user2 password simple hello

[ccieh3c.qzone.qq.com-RouterB-Dialer1] quit

# 配置 PPPoE 会话。
[ccieh3c.qzone.qq.com-RouterB] interface ethernet 1/1

[ccieh3c.qzone.qq.com-RouterB-Ethernet1/1] pppoe-client dial-bundle-number 1

方案二:CHAP 认证
(1)
配置 Router A 作为 PPPoE Server

# 增加一个 PPPoE 用户。

<ccieh3c.qzone.qq.com-RouterA> system-view

[ccieh3c.qzone.qq.com-RouterA] local-user user2

[ccieh3c.qzone.qq.com-RouterA-luser-user2] password simple hello

[ccieh3c.qzone.qq.com-RouterA-luser-user2] service-type ppp

[ccieh3c.qzone.qq.com-RouterA-luser-user2] quit

# 配置虚拟模板参数。

[ccieh3c.qzone.qq.com-RouterA] interface virtual-template 1

[ccieh3c.qzone.qq.com-RouterA-Virtual-Template1] ppp authentication-mode chap

[ccieh3c.qzone.qq.com-RouterA-Virtual-Template1] ppp chap user user1

[ccieh3c.qzone.qq.com-RouterA-Virtual-Template1] ip address 1.1.1.1 255.0.0.0

[ccieh3c.qzone.qq.com-RouterA-Virtual-Template1] remote address 1.1.1.2

[ccieh3c.qzone.qq.com-RouterA-Virtual-Template1] quit

# 配置 PPPoE Server。

[ccieh3c.qzone.qq.com-RouterA] interface ethernet 1/1

[ccieh3c.qzone.qq.com-RouterA-Ethernet1/1] pppoe-server bind virtual-template 1

(2)
配置 Router B 作为 PPPoE Client

<ccieh3c.qzone.qq.com-RouterB> system-view

[ccieh3c.qzone.qq.com-RouterB] dialer-rule 1 ip permit

[ccieh3c.qzone.qq.com-RouterB] interface dialer 1

[ccieh3c.qzone.qq.com-RouterB-Dialer1] dialer user user2

[ccieh3c.qzone.qq.com-RouterB-Dialer1] dialer-group 1

[ccieh3c.qzone.qq.com-RouterB-Dialer1] dialer bundle 1

[ccieh3c.qzone.qq.com-RouterB-Dialer1] ip address ppp-negotiate

[ccieh3c.qzone.qq.com-RouterB-Dialer1] ppp chap user user2

[ccieh3c.qzone.qq.com-RouterB-Dialer1] quit

[ccieh3c.qzone.qq.com-RouterB] local-user user1

[ccieh3c.qzone.qq.com-RouterB-luser-user1] password simple hello

[ccieh3c.qzone.qq.com-RouterB-luser-user1] quit

# 配置 PPPoE 会话。

[ccieh3c.qzone.qq.com-RouterB] interface ethernet 1/1

[ccieh3c.qzone.qq.com-RouterB-Ethernet1/1] pppoe-client dial-bundle-number 1

利用 ADSL Modem 将局域网接入 Internet

1. 组网需求 l
局域网内的计算机通过 Router A 访问 Internet,Router A 通过 ADSL Modem 采用永久在线的方式接入 DSLAM。
l
ADSL 帐户的用户名为 user1,密码为 123456。
l
Router B 作为 PPPoE Server 通过 ATM2/0 接口连接至 DSLAM,提供 RADIUS 认证、计费功能。
l
在 Router A 上使能 PPPoE Client 功能,局域网内的主机不用安装 PPPoE 客户端软件即可访问 Internet

配置步骤
(1)
配置 Router A 作为 PPPoE Client
# 配置 Dialer 接口。

<ccieh3c.qzone.qq.com-RouterA> system-view

[ccieh3c.qzone.qq.com-RouterA] dialer-rule 1 ip permit

[ccieh3c.qzone.qq.com-RouterA] interface dialer 1

[ccieh3c.qzone.qq.com-RouterA-Dialer1] dialer-group 1

[ccieh3c.qzone.qq.com-RouterA-Dialer1] dialer bundle 1

[ccieh3c.qzone.qq.com-RouterA-Dialer1] ip address ppp-negotiate

[ccieh3c.qzone.qq.com-RouterA-Dialer1] ppp pap local-user user1 password cipher 123456

[ccieh3c.qzone.qq.com-RouterA-Dialer1] quit

# 配置 PPPoE 会话。
[ccieh3c.qzone.qq.com-RouterA] interface ethernet 1/2

[ccieh3c.qzone.qq.com-RouterA-Ethernet1/2] pppoe-client dial-bundle-number 1

[ccieh3c.qzone.qq.com-RouterA-Ethernet1/2] quit

# 配置局域网接口及缺省路由。

[ccieh3c.qzone.qq.com-RouterA] interface ethernet 1/1

[ccieh3c.qzone.qq.com-RouterA-Ethernet1/1] ip address 192.168.1.1 255.255.255.0

[ccieh3c.qzone.qq.com-RouterA-Ethernet1/1] quit

[ccieh3c.qzone.qq.com-RouterA] ip route-static 0.0.0.0 0 dialer 1

如果局域网内计算机使用的 IP 地址为私有地址,还需要在设备上配置 NAT(Network Address Translation,网络地址转换)。
NAT 的相关内容请参见“安全分册”中的“NAT 配置”。

(2)
配置 Router B 作为 PPPoE Server

# 增加一个 PPPoE 用户。

<ccieh3c.qzone.qq.com-RouterB> system-view

[ccieh3c.qzone.qq.com-RouterB] local-user user1

[ccieh3c.qzone.qq.com-RouterB-luser-user1] password simple 123456

[ccieh3c.qzone.qq.com-RouterB-luser-user1] service-type ppp

[ccieh3c.qzone.qq.com-RouterB-luser-user1] quit

# 对 ATM 口进行配置。

[ccieh3c.qzone.qq.com-RouterB] interface atm 1/0

[ccieh3c.qzone.qq.com-RouterB-Atm1/0] pvc 0/32

[ccieh3c.qzone.qq.com-RouterB-atm-pvc-Atm1/0-0/32] map bridge vrtual-ethernet 1

[ccieh3c.qzone.qq.com-RouterB-atm-pvc-Atm1/0-0/32] quit

[ccieh3c.qzone.qq.com-RouterB-Atm1/0] quit

# 在 Virtual-Ethernet 接口上使能 PPPoE Server。

[ccieh3c.qzone.qq.com-RouterB] interface virtual-ethernet 1

[ccieh3c.qzone.qq.com-RouterB-Virtual-Ethernet1] pppoe-server bind virtual-template 1

[ccieh3c.qzone.qq.com-RouterB-Virtual-Ethernet1] quit

# 配置虚拟模板参数。
[ccieh3c.qzone.qq.com-RouterB] interface virtual-template 1

[ccieh3c.qzone.qq.com-RouterB-Virtual-Template1] ppp authentication-mode pap domain system

[ccieh3c.qzone.qq.com-RouterB-Virtual-Template1] remote address pool 1

[ccieh3c.qzone.qq.com-RouterB-Virtual-Template1] ip address 1.1.1.1 255.0.0.0

[ccieh3c.qzone.qq.com-RouterB-Virtual-Template1] quit

# 配置域用户使用 RADIUS 认证方案。

[ccieh3c.qzone.qq.com-RouterB] domain system

[ccieh3c.qzone.qq.com-RouterB-isp-system] authentication ppp radius-scheme cams

# 增加一个本地 IP 地址池(9 个 IP 地址)。

[ccieh3c.qzone.qq.com-RouterB-isp-system] ip pool 1 1.1.1.2 1.1.1.10

[ccieh3c.qzone.qq.com-RouterB-isp-system] quit

# 配置 RADIUS 方案以及 RADIUS 认证/授权/计费服务器的 IP 地址和端口号。

[ccieh3c.qzone.qq.com-RouterB] radius scheme cams

[ccieh3c.qzone.qq.com-RouterB-radius-cams] primary authentication 10.110.91.146 1812

[ccieh3c.qzone.qq.com-RouterB-radius-cams] primary accounting 10.110.91.146 1813

[ccieh3c.qzone.qq.com-RouterB-radius-cams] key authentication expert

[ccieh3c.qzone.qq.com-RouterB-radius-cams] key accounting expert

[ccieh3c.qzone.qq.com-RouterB-radius-cams] server-type extended

[ccieh3c.qzone.qq.com-RouterB-radius-cams] user-name-format with-domain

[ccieh3c.qzone.qq.com-RouterB-radius-cams] quit

利用 ADSL 做备份线路
1. 组网需求

Router 通过 DDN 专线和 ADSL 线路和网络中心 NetworkCenter 相连,其中 ADSL 线路作为 DDN 专线的备份。当 DDN
专线发生故障时,Router 仍然可以发起 PPPoE 呼叫通过 ADSL 线路连接到网络中心。如果在 ADSL 线路上有 2 分钟没有报
文传输,则 PPPoE 会话将被自动中止。之后如果有新的报文需要被发送,则 PPPoE 会话会被重新建立。

配置步骤
配置 Router
# 配置 Dialer 接口。
<Router> system-view

[Router] dialer-rule 1 ip permit

[Router] interface dialer 1

[Router-Dialer1] dialer user user1

[Router-Dialer1] dialer-group 1

[Router-Dialer1] dialer bundle 1

[Router-Dialer1] ip address ppp-negotiate

# 配置 PPPoE 会话。

[Router-Dialer1] interface ethernet 1/1

[Router-Ethernet1/1] pppoe-client dial-bundle-number 1 idle-timeout 120

[Router-Ethernet1/1] quit

# 配置 DDN 接口 Serial2/0。

[Router] interface serial 2/0

[Router-Serial2/0] ip address 10.1.1.1 255.255.255.0

[Router-Serial2/0] standby interface dialer 1

[Router-Serial2/0] quit

# 配置到对端的静态路由。

[Router] ip route 0.0.0.0 0 serial 2/0 preference 60

[Router] ip route 0.0.0.0 0 dialer 1 preference 70

设备通过 ADSL 接口接入 Internet
1. 组网需求
Router 拥有 ADSL 接口 ATM1/0,它通过 ADSL 接口直接连入 Internet,而不用再连接 ADSL Modem。
配置步骤
# 配置 Dialer 接口。
<Router> system-view

[Router] dialer-rule 1 ip permit

[Router] interface dialer 1

[Router-Dialer1] dialer user mypppoe

[Router-Dialer1] dialer-group 1

[Router-Dialer1] dialer bundle 1

[Router-Dialer1] ip address ppp-negotiate

# 配置 Virtual-Ethernet 接口。
[Router-Dialer1] interface virtual-ethernet 1

[Router-Virtual-Ethernet1] mac 0001-0002-0003

[Router-Virtual-Ethernet1] quit

[Router]interface atm 1/0.1

[Router-atm1/0.1]pvc to_adsl_a 0/60

[Router-atm-pvc-atm1/0.1-0/60-to_adsl_a] map bridge virtual-ethernet 1

[Router-atm-pvc-atm1/0.1-0/60-to_adsl_a] quit

[Router-atm1/0.1] quit

配置 PPPoE 会话。
[Router] interface virtual-ethernet 1

[Router-Virtual-Ethernet1] pppoe-client dial-bundle-number 1 idle-timeout 120

[Router-Virtual-Ethernet1] quit
# 配置缺省路由。

[Router]ip route-static 0.0.0.0 0.0.0.0 dialer 1
目前CCIE RS 笔试和LAB 稳定,持续过人中,了解之前的PASS情况和咨询考试情况

请加QQ:804990984 , 83989824
技术交流请加群:859273036,备注博客

扫描二维码也可以加群哦:
技术交流群.jpg
 您阅读这篇文章共花了: 
 本文无需标签!
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:859273036 互相学习。     
本文地址:http://www.023wg.com/704.html
版权声明:若无注明,本文皆为“思唯网络学院博客”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:思唯网络学院博客    浙江思唯网络