【思唯网络学院】Cisco 路由器 PPPOE client 拨号配置
首页 > >   作者:浙江思唯网络  2019年12月3日 14:28 星期二  字号:   评论:0 条
时间:2019-12-3 14:28   评论:0 条 


Cisco 路由器 PPPOE client 拨号配置


1、接口下调用 PPPOE-client

ccieh3c.qzone.qq.com-pppoe_client(config)#interface e0/0

ccieh3c.qzone.qq.com-pppoe_client(config-if)#pppoe-client dial-pool-number 1

ccieh3c.qzone.qq.com-pppoe_client(config-if)#no shutdown

2、PPPOE-client 接口的配置
ccieh3c.qzone.qq.com-pppoe_client(config)#interface dialer 1

ccieh3c.qzone.qq.com-pppoe_client(config-if)#encapsulation ppp 【在思科上面默认为 HDLC】

ccieh3c.qzone.qq.com-pppoe_client(config-if)#ip address negotiated 【地址通过协商获取】

如果运营商那边认证方式为 PAP 则配置如下

ccieh3c.qzone.qq.com-pppoe_client(config-if)#ppp authentication pap calin 【开启 PAP 认证,注意这里是单向的】

ccieh3c.qzone.qq.com-pppoe_client(config-if)#ppp pap sent-username ccieh3c password ccieh3c.taobao.com

如果运营商那边认证方式为 CHAP 则配置如下
ccieh3c.qzone.qq.com-pppoe_client(config-if)#ppp authentication chap callin

ccieh3c.qzone.qq.com-pppoe_client(config-if)#ppp chap hostname ccieh3c

ccieh3c.qzone.qq.com-pppoe_client(config-if)#ppp chap password ccieh3c.taobao.com

如果不确定运营商那边是什么方式的话,还有一种办法
ccieh3c.qzone.qq.com-pppoe_client(config-if)#ppp authentication chap pap callin

然后输入 pap 跟 chap 两种方式,这样无论运营商是哪种都可以成功。

ccieh3c.qzone.qq.com-pppoe_client(config-if)#ip mtu 1492

ccieh3c.qzone.qq.com-pppoe_client(config-if)#ip tcp adjust-mss 1420

ccieh3c.qzone.qq.com-pppoe_client(config-if)#dialer pool 1 【跟接口输入的 nmuber 号一致】

3、物理接口调用
ccieh3c.qzone.qq.com-pppoe_client(config)#int f0/0

ccieh3c.qzone.qq.com-pppoe_client(config-if)#pppoe-client dial-pool-number 1
可以看到虚拟接口已经起来,也获取到了 IP 地址。

4、配置路由与 NAT
ccieh3c.qzone.qq.com-pppoe_client(config)#ip route 0.0.0.0 0.0.0.0 dialer 1 permanent

该 permanent 参数可以让默认路由永久存在,可以根据需求来决定是否定义

ccieh3c.qzone.qq.com-pppoe_client(config)#ip access-list extended nat

ccieh3c.qzone.qq.com-pppoe_client(config-ext-nacl)#permit ip 192.168.1.0 0.0.0.255 any

ccieh3c.qzone.qq.com-pppoe_client(config)#ip nat inside source list nat interface dialer 1 overload

ccieh3c.qzone.qq.com-pppoe_client(config)#int lo 0

ccieh3c.qzone.qq.com-pppoe_client(config-if)#ip nat inside

ccieh3c.qzone.qq.com-pppoe_client(config-if)#exit

ccieh3c.qzone.qq.com-pppoe_client(config)#int dialer 1

ccieh3c.qzone.qq.com-pppoe_client(config-if)#ip nat outside

说明:这里用环回口来做测试,另外 nat 的调用是在 dialer 口,而不是物理接口。

5、测试
可以正常访问外网了。

Cisco 防火墙 PPPOE client 拨号配置
1、配置 PPPOE 部分
ccieh3c.qzone.qq.com-ASA(config)# vpdn group isp request dialout pppoe

ccieh3c.qzone.qq.com-ASA(config)# vpdn group isp ppp authentication pap

ccieh3c.qzone.qq.com-ASA(config)# vpdn username ccieh3c password ccieh3c.taobao.com

ccieh3c.qzone.qq.com-ASA(config)# vpdn group isp localname ccieh3c

2、调用到接口
ccieh3c.qzone.qq.com-ASA(config)# interface e0

ccieh3c.qzone.qq.com-ASA(config-if)# nameif outside

ccieh3c.qzone.qq.com-ASA(config-if)# pppoe client vpdn group isp

ccieh3c.qzone.qq.com-ASA(config-if)# ip address pppoe setroute 【该参数必须敲,否则会没有默认路由】

ccieh3c.qzone.qq.com-ASA(config-if)# no shutdown

3、检查是否正确获取到地址跟路由
E1 是内网接口,已经配置好了的,外网接口是通过 PPPOE 获取到的。
已经有路由了,注意如果 ip address pppoe setroute ,没敲 setroute 的话,那么 ASA 是没有默认路由的。
通过 show vpdn group 是可以查看配置的,如果发现获取不到地址的话,可以改 PAP 为 CHAP

4、NAT 配置
ccieh3c.qzone.qq.com-ASA(config)# nat (inside) 1 192.168.1.0 255.255.255.0

ccieh3c.qzone.qq.com-ASA(config)# global (outside) 1 interface

ccieh3c.qzone.qq.com-ASA(config)# access-list permit-icmp permit icmp any any

ccieh3c.qzone.qq.com-ASA(config)# access-group permit-icmp in interface outside

说明:这里放行 ICMP 是为了方便测试

5、验证

目前CCIE RS 笔试和LAB 稳定,持续过人中,了解之前的PASS情况和咨询考试情况

请加QQ:804990984 , 839898248

技术交流请加群:859273036,备注博客

扫描二维码也可以加群哦:
技术交流群.jpg
 您阅读这篇文章共花了: 
 本文无需标签!
二维码加载中...
技术交流:欢迎在本文下方留言或加入QQ群:859273036 互相学习。     
本文地址:http://www.023wg.com/703.html
版权声明:若无注明,本文皆为“思唯网络学院博客”原创,转载请保留文章出处。

返回顶部    首页   
版权所有:思唯网络学院博客    浙江思唯网络